Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 339 - lpd restricts remote users to those with local accounts
Summary: lpd restricts remote users to those with local accounts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr
Version: 5.2
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
: 1994 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-08 02:03 UTC by amlai
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-17 17:08:47 UTC


Attachments (Terms of Use)

Description amlai 1998-12-08 02:03:00 UTC
lpd restricts remote users to those with local accounts even
without the rs flag in the printcap.

Comment 1 Bill Nottingham 1999-02-17 17:07:59 UTC
fixed in lpr-0.34-1

Comment 2 Jeff Johnson 1999-04-05 14:26:59 UTC
*** Bug 1994 has been marked as a duplicate of this bug. ***

lpr-0.31-4 (RH5.1) printing to lpr-0.33-1 (RH5.0) doesn't
work if remote host doesn't not have user account for
client.

lpd log shows:
Apr  2 17:55:12 star lpd[31169]: can't find user - can't
fork

This occurs regardless of rs: flag in printcap.  Printing is
fine when accounts match (root<->root, etc.).
(This is in Debian Bug List also)


Note You need to log in before you can comment on or make changes to this bug.