Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3379 - dvi files print by default on a4 paper
Summary: dvi files print by default on a4 paper
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 3512 5192 6900 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-10 03:39 UTC by rychlik
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-12 22:31:49 UTC


Attachments (Terms of Use)

Description rychlik 1999-06-10 03:39:43 UTC
When printer is PostScript, and a .dvi file is printed,
the PostScript file produced by dvips has paper size set
to a4 by default, and incorrectly printed on letter size
paper. The user can fix the problem by doing
	export DVIPS_OPTIONS='-t letter'
at command line or putting this line in .bashrc.
The variable DVIPS_OPTIONS seems to be undocumented and
it is used in /usr/lib/rhs/rhs-printfilters/dvi-to-ps.fpi.
It is nowhere set. I think it was meant to be set based
on /var/spool/lpd/lp/postscript.cfg. This is a modified
dvi-to-ps.fpi which does the trick:


#!/bin/sh
#
# convert TeX dvi to Postscript
#
#

#
# read in PostScript configuration settings
#
source ${SPOOLDIR}/postscript.cfg

DVIPS_OPTIONS="-t $PAPERSIZE"

#
# will want to source print options for dvips
#
TMP_FILE=`mktemp /tmp/rhsprintfilter.XXXXXX` || exit 1
cat > $TMP_FILE
dvips -f $DVIPS_OPTIONS < $TMP_FILE

if [ -f "$TMP_FILE" ]; then
      rm -f $TMP_FILE
fi

exit 0

Comment 1 Jay Turner 1999-06-29 15:13:59 UTC
This issue has been forwarded to a developer for further action.

Comment 2 Cristian Gafton 1999-07-28 23:06:59 UTC
assigned to jbj

Comment 3 Jeff Johnson 1999-08-12 22:31:59 UTC
Fixed in Raw Hide tetex-1.0.6-1. Thanks for the script.

Comment 4 Jeff Johnson 1999-08-12 22:34:59 UTC
*** Bug 3512 has been marked as a duplicate of this bug. ***

     The default paper size is A4, with the result that when
using standard
American letter paper Tex output is not centered.  The
manual should instruct
people to add a line   t letter  to the
/usr/share/texmf/dvips/config/config.ps
file, which fixes it.

Comment 5 Jeff Johnson 2000-01-15 21:15:59 UTC
*** Bug 5192 has been marked as a duplicate of this bug. ****** Bug 6900 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.