Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3376 - set -o vi breaks bash when it occurs in .bash_profile
Summary: set -o vi breaks bash when it occurs in .bash_profile
Keywords:
Status: CLOSED DUPLICATE of bug 2738
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-09 22:47 UTC by alanr
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-10 14:51:12 UTC


Attachments (Terms of Use)

Description alanr 1999-06-09 22:47:38 UTC
When you put "set -o vi" in a .bash_profile in Red Hat 6.0,
vi mode doesn't work at all.  When you type it in manually,
it works fine.  This seems like a bug in readline, not a
choice of features as Cristian Grafton has suggested.  When
one adds "set -o vi" to a .bashrc, then vi edit mode never
works correctly afterwards.  When you type it in manually,
you get great results.  Once bash processes the "set -o vi"
in a .bashrc, no amount changing edit modes manually will
make vi edit mode work correctly [emacs edit mode seems
unaffected].

It makes the system MUCH more unfriendly to vi users than
the old version was to emacs users.  Yeah, home and end
work, but now nothing else does - at least not for vi users.

The workaround is given by David A. DeGraaf on the
hedwig-list:

I found that the new line in /etc/profile is culpable:
       INPUTRC=/etc/inputrc
When I commented this out bash worked again as it should.  I
have no idea why this line is there or what function is lost
by removing it.  It's just one of those little mysteries...

Comment 1 Jay Turner 1999-06-10 14:51:59 UTC
*** This bug has been marked as a duplicate of 2738 ***


Note You need to log in before you can comment on or make changes to this bug.