Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3368 - libpcap RPM has a problem in RHL6.0, and RHL5.2
Summary: libpcap RPM has a problem in RHL6.0, and RHL5.2
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 4173 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-09 16:04 UTC by jlorenz
Modified: 2016-12-15 00:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-03 21:54:43 UTC


Attachments (Terms of Use)

Description jlorenz 1999-06-09 16:04:11 UTC
The rpm for 'libpcap' in RedHat Linux 6.0 and 5.2 has an
issue with header file locations.  The man page for 'pcap'
clearly indicates "#include <pcap.h>" implying that the
file should be located in the standard include path.

The rpm installation places 'pcap.h' in /usr/include/pcap
directory, so the file isn't found.  If you change your
source to "#include <pcap/pcap.h>" it still causes a
problem because 'pcap.h' has a line "#include <net/bpf.h>"
and that file can't be found.

Back in PowerTools 5.1, the libpcap rpm properly installed
pcap.h in /usr/include and bpf.h in /usr/include/net and
things worked fine (the way the authors intended).

There is no SRPM for libpcap (another issue) so I cannot
submit a patch to the SPEC file.

My recommeded resolution is that the rpm for 'libpcap' needs
to install all header files under the /usr/include tree,
and not create a new /usr/include/pcap directory to place
files under.

Comment 1 Jeff Johnson 1999-06-09 16:15:59 UTC
Tcpdump contains libpcap so I'm changing the component

Comment 2 van der Kooij, Hugo 1999-07-04 15:17:59 UTC
When will there be a fixed libpcap package be made available?

Comment 3 Jeff Johnson 1999-07-06 16:14:59 UTC
Change whatever program you are compiling to include
"-I/usr/include/pcap" -- that will work no matter where
pcap.h ends up.

At the moment, I suspect the fix will be to change the documentation
and to install bpf.h in /usr/include/pcap as well ...

Comment 4 Jeff Johnson 1999-07-23 08:46:59 UTC
*** Bug 4173 has been marked as a duplicate of this bug. ***

This is technically NOT a net-tools bug report, but:

libpcap rpm does not have include files, libpcap-devel
does not exist and finally - libpcap entry is missing
from Bugzilla component selector on "enter Bug" page.
(It does exist on query page.)

Regards,
Dmitri.

Comment 5 Dmitri A. Sergatskov 1999-07-23 15:37:59 UTC
tcpdump does not depend on libpcap rpm being installed -
it is apparently linked statically.
Wrong location for include files screwd up 'configure' script
for at least some programs, so "-I/usr/include/pcap" fix does not
really works.
So, my solution is to uninstall libpcap rpm and compile the thing
from scratch.

Comment 6 Jeff Johnson 1999-08-03 21:54:59 UTC
Your configuration problem is best resolved by doing
	cd /usr/include
	ln -s pcap/pcap.h
	ln -s ../pcap/net/bpf.h net/bpf.h
Otherwise, adding -I/usr/include/pcap to the compile flags will find
pcap.h and net/bpf.h for the handful of programs that need to
compile against libpcap.
correctly

Comment 7 openshift-github-bot 2016-12-15 00:49:50 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/92684406480950d7e1b01c775bc32537ddd70424
Merge pull request #3386 from bfallonf/maven_issue3368

Issue 3368 Commented out maven section


Note You need to log in before you can comment on or make changes to this bug.