Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 336721 - XDMCP segfaults gdmgreeter (libkeymouselistener)
Summary: XDMCP segfaults gdmgreeter (libkeymouselistener)
Keywords:
Status: CLOSED DUPLICATE of bug 246399
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: K12LTSP
TreeView+ depends on / blocked
 
Reported: 2007-10-17 21:09 UTC by Warren Togami
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-17 21:39:28 UTC


Attachments (Terms of Use)

Description Warren Togami 2007-10-17 21:09:25 UTC
gdm-2.20.1-2.fc8

Enable XDMCP and attempt to connect with:
Xnest :1 -query localhost

gdmgreeter segfaults.

Workaround:
GtkModulesList=gail:atk-bridge:/usr/lib64/gtk-2.0/modules/libkeymouselistener
Remove /usr/lib64/gtk-2.0/modules/libkeymouselistener in custom.conf.

Backtrace below:

(gdb) bt full
#0  gtk_module_init (argc=<value optimized out>, argv=<value optimized out>) at
keymouselistener.c:172
No locals.
#1  0x00002aaaaac40449 in load_modules (module_str=<value optimized out>) at
gtkmodules.c:311
        module_names = (gchar **) 0x65eac0
        module_list = (GSList *) 0x69ee00
#2  0x00002aaaaac406fd in _gtk_modules_init (argc=0x0, argv=0x0,
gtk_modules_args=0x65d380
"gail:atk-bridge:/usr/lib64/gtk-2.0/modules/libkeymouselistener") at
gtkmodules.c:514
        display_manager = (GdkDisplayManager *) 0x65c040
        i = 457664700
        __PRETTY_FUNCTION__ = "_gtk_modules_init"
#3  0x00002aaaaac24820 in post_parse_hook (context=<value optimized out>,
group=<value optimized out>, data=0x65a040, error=0x7fff1b476908) at gtkmain.c:673
        e = <value optimized out>
#4  0x00000032cb43ba95 in IA__g_option_context_parse (context=0x65cad0,
argc=0x7fff1b47698c, argv=0x7fff1b476980, error=0x7fff1b476908) at goption.c:1753
        arg = (gchar *) 0x7fff1b477a83
"gtk-module=gail:atk-bridge:/usr/lib64/gtk-2.0/modules/libkeymouselistener"
        dash = <value optimized out>
        parsed = 1
        stop_parsing = 0
        has_unknown = 0
        separator_pos = <value optimized out>
        i = 2
        j = <value optimized out>
        k = <value optimized out>
        list = <value optimized out>
#5  0x00002aaaaac2445f in IA__gtk_parse_args (argc=0x7fff1b47698c,
argv=0x7fff1b476980) at gtkmain.c:859
        option_context = (GOptionContext *) 0x65cad0
        gtk_group = <value optimized out>
        error = (GError *) 0x0
#6  0x00002aaaaac244b9 in IA__gtk_init_check (argc=0x0, argv=0x7369645f) at
gtkmain.c:895
No locals.
#7  0x00002aaaaac244e9 in IA__gtk_init (argc=0x0, argv=0x7369645f) at gtkmain.c:933
No locals.
#8  0x000000000040ba2c in main (argc=2, argv=0x7fff1b476c88) at greeter.c:1282
        bg_color = <value optimized out>
        hup = {__sigaction_handler = {sa_handler = 0x100000000, sa_sigaction =
0x100000000}, sa_mask = {__val = {4294969272, 1, 46912496120664,
140733651053520, 140733651053440, 
      4131212846, 140733651053464, 46912510026024, 232123306991, 0,
46912510026024, 140733193388033, 0, 46909632806913, 6505168, 0}}, sa_flags =
360792976, sa_restorer = 0x6344f0}
        term = {__sigaction_handler = {sa_handler = 0x634554, sa_sigaction =
0x634554}, sa_mask = {__val = {46912510003584, 140733651053344, 232123305451,
4287062190, 
      46912510025616, 23, 65, 0, 232123306481, 140733651053056, 140733651053440,
140733651053464, 232127478584, 0, 46912510026024, 46912507453312}}, sa_flags =
4218028, 
  sa_restorer = 0x360be10000}
        mask = {__val = {46912496120664, 140733651053568, 46912496119808,
4218028, 199272512, 232317443584, 140733651053728, 140733651053728,
140733651053704, 2, 0, 232123322677, 
    231928233985, 0, 0, 232125475776}}
        ctrlch = <value optimized out>
        error = <value optimized out>
        theme_file = <value optimized out>
        theme_dir = <value optimized out>
        gdm_graphical_theme = <value optimized out>
        gdm_gtk_theme = <value optimized out>
        sid = <value optimized out>
        r = <value optimized out>
        i = <value optimized out>
        key_string = <value optimized out>
#9  0x000000360be1e074 in __libc_start_main (main=0x40b960 <main>, argc=2,
ubp_av=0x7fff1b476c88, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff1b476c78) at libc-start.c:220
        result = <value optimized out>
---Type <return> to continue, or q <return> to quit---
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {232125475776,
-9154506479098075231, 0, 140733651053696, 0, 0, 9154303271705831329,
-9180377696720984159}, mask_was_saved = 0}}, 
  priv = {pad = {0x0, 0x0, 0x4247c0, 0x7fff1b476c88}, data = {prev = 0x0,
cleanup = 0x0, canceltype = 4343744}}}
        not_first_call = <value optimized out>
#10 0x000000000040b3a9 in _start ()
No symbol table info available.

Comment 1 Ray Strode [halfline] 2007-10-17 21:39:28 UTC

*** This bug has been marked as a duplicate of 246399 ***


Note You need to log in before you can comment on or make changes to this bug.