Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3364 - Oops 0000 with kernel 2.2.5-15smp
Summary: Oops 0000 with kernel 2.2.5-15smp
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 3365 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-09 15:45 UTC by desnoyers.alexandre
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-02 22:32:01 UTC


Attachments (Terms of Use)

Description desnoyers.alexandre 1999-06-09 15:45:20 UTC
I had this at my screen this morning...

[root@nbpu /etc]# Unable to handle kernel NULL pointer
dereference at
virtual address 00000008
current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 00000000
Oops: 0000
CPU:    1
EIP:    0010:[<c011e590>]
EFLAGS: 00010202
eax: 00000000   ebx: c7645060   ecx: c67df960   edx:
00000000
esi: 40012000   edi: c0fbde60   ebp: 00001000   esp:
c7e31f78
ds: 0018   es: 0018   ss: 0018
Process sleep (pid: 27408, process nr: 34,
stackpage=c7e31000)
Stack: c7e30000 c7e31fb4 c67df960 c011439c c0fbde60 c0fbde60
c0fbde60 c0118f2d
       c0fbde60 c7e30000 40101f04 00000000 00000000 ffffd38
c7e30000 bffffd6c
       c011911f 00000000 c0108b6c 00000000 401001e8 401021b4
40101f04 00000000
Call Trace:

(from /var/log/messages)
[mmput+28/52] [do_exit+241/724] [sys_exit+15/16]
[system_call+52/56]
(end)

[<c011439c>] [<c0118f2d>] [<c011911f>] [<c0108b6c>]
Code: 8b 40 08 ff 80 90 00 00 00 8b 53 20 85 d2 74 09 8b 43
24 89

the process sleep who supposedly cause the problem was
running from this shell script:

# Little shell script to continuously display the status of
# samba
# (the "echo SAMBA;" is to loop indefinitly...)
#
#!/bin/bash
while { echo SAMBA; } do {
    smbstatus;
    sleep 2;
    clear;
} done

This program ran for about 4 hours before crashing.


My computer is a dual P-II 333Mhz, 128Mb Ram, 2x 8.4Gb HD,
/home mounted in raid linear to /dev/md0, samba 2.0.4b

If you need more informations, E-Mail me and I will send you
what you need.

Thank you

Alexandre Desnoyers

Comment 1 Jeff Johnson 1999-06-09 16:19:59 UTC
Could you please attach the oops text as a reply to this message?
Fishing all that info out of html is the pits :-(

Thanks

Comment 2 Jay Turner 1999-06-29 15:01:59 UTC
This issue has been forwarded to a developer for further action.

Comment 3 Jay Turner 1999-06-29 15:02:59 UTC
*** Bug 3365 has been marked as a duplicate of this bug. ***

Please forgive the poor formatting.
The following is a panic we received at 6:54am PST using the
stock 2.2.5-22smp kernel recently released. Our server
locked up with no console response with the following on the
screen:

Unable to handle kernel null pointer dereference at virtual
address 00000066
current.tss.cr3=00101000 %cr3=00101000
*pdc = 00000000
oops: 0000
cpu: 1
eip 0010:[<c0167240>]
eflags: 00010246
eax: 00000000 ebx: f3f62260 ecx: 00000000 edx: 00000000
esi: d285a230 edi: f3f62260 ebp: c0fade1c esp: c0fade08
ds: 0018  es: 0018  ss: 0018
process swapper (pid:0, process nr:1, stackpage = c0fad000)
stack: 000005b4 00000000 c001f620 c014fe5c c001f620
d285a180 c016756b d285a180 f3f62260 000005b4
d285a180 d285a230 d285a1d4 d285a180 c0167695
d285a180 f3f62260 d285a230 ffffff06 c0164b4f
d285a180 d285a230 d285a180

call trace: [<c014fe5e>] [<c013dcff>] [<c015df91>]
[<c0151d21>] [<c011a0d9>] [<c010b039>] [<c0108c08>]
[<c010736c>] [<c01075db>]

code: 80 79 66 00 74 13 8b 81 88 00 00 00 8b 00 83 f8 01 0f
95 c0

Aiee killing interrupt handler
Kernel panic: Attempted to kill the idle task!
in interrupt handler - not syncing



------- Additional Comments From jbj@redhat.com  06/09/99 12:24 -------
Could you reply to this message with the oops text attached?
I hate html :-(
Thanks.

------- Email Received From  "Michael A. Folmer" <mike@myhome.net> 06/09/99 23:10 -------

Comment 4 Cristian Gafton 1999-07-02 22:32:59 UTC
Alan, any clues on these ones? I am hinting for HW problems, but you
might want to take a look first. Please reopen if you do not agree.

Unless proven otherwise, this bug is closed as being caused by a h/w
problem.


Note You need to log in before you can comment on or make changes to this bug.