Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 335711 - Why not warzone on x86_64 and ppc64 and...
Summary: Why not warzone on x86_64 and ppc64 and...
Keywords:
Status: CLOSED DUPLICATE of bug 223992
Alias: None
Product: Fedora
Classification: Fedora
Component: warzone2100
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Karol Trzcionka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-17 07:22 UTC by Oliver Falk
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-17 14:49:07 UTC


Attachments (Terms of Use)

Description Oliver Falk 2007-10-17 07:22:27 UTC
While rebuilding the fcdevel tree for AlphaCore, I recognized, that x86_64 and
ppc64 are excluded in warzone2100. Well when I rebuild it on alpha, at some
point (http://buildsys.zero42.at/koji/getfile?taskID=47748&name=build.log), gcc
gets invoked with -m32; Well that might be the ExcludeArch reason for x86_64 and
ppc64...

So either fix the -m32, or use ExclusiveArch: ppc i386.

What does upstream say? Does it only work on 32 bit archs!?

Comment 1 Karol Trzcionka 2007-10-17 14:49:07 UTC
warzone2100 is prepared only for 32-bit archs. Upstream works on it and the new
version from cvs compiles correctly on 64-bit.

*** This bug has been marked as a duplicate of 223992 ***

Comment 2 Oliver Falk 2007-10-17 14:58:41 UTC
Can you please update or use ExclusiveArch until the code is clean and in cvs!?

Comment 3 Karol Trzcionka 2007-10-17 15:26:58 UTC
Ok, I've changed the 
ExcludeArch: x86_64 ppc64
to
ExclusiveArch: ppc i386


Note You need to log in before you can comment on or make changes to this bug.