Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3357 - nfs is painfully slow
Summary: nfs is painfully slow
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-09 03:46 UTC by Bill Chatfield
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-28 07:43:58 UTC


Attachments (Terms of Use)

Description Bill Chatfield 1999-06-09 03:46:36 UTC
This may be a result of changing nfs code in the kernel, but
it would be nice to know what the problem is and when it is
likely to be fixed.

Basically, copying a file from an nfs mounted volume to a
local disk (both client and server are RH6 machines) is more
than 3 times slower than ftping the same file.  Sometime the
nfs transfer just stops for "long" periods of time.  The
machines I'm working with are on the same network segment on
an unloaded network.

I've already tried using the rsize and wsize mount options
for nfs.  They have little to no effect.

Comment 1 Bill Chatfield 1999-06-09 03:56:59 UTC
Forgot to make this high priority/severity.  This is really critical
as I am going to have to stop using my Linux workstation and go back
to Windows and smb to get acceptible peformance from our Linux file
server.

Linux-smb-Linux does not work for mounting home directories.
Permissions, file name case, and dot files are all messed up.  You
have to use nfs not smb for home directories.

Comment 2 Jay Turner 1999-06-29 14:43:59 UTC
Are you running knfsd?  We do not see this kind of performance
degradation here in the office.

------- Email Received From  Bill Chatfield <bill.chatfield@netcommunity.com> 06/29/99 11:09 -------

Comment 3 Bill Chatfield 1999-07-13 22:54:59 UTC
I do believe we are running knfsd because lsmod says I have an nfs
kernel module loaded.

I would be happy to provide telnet access to a Red Hat person so you
could see the problem where it is happening.  Just let me know.

BTW: Going back to using Windows was a threat I couldn't live up to.

Comment 4 Cristian Gafton 1999-07-28 07:43:59 UTC
The NFS is slow, but it should not be that painfully slow. What is the
size of the file you are dealing with?

On a related thing, Samba can be instrumented to preserve the case for
filenames, it just does not do it by default.

On a 100mbit network the NFS server will peak at about 1.9MB/sec,
while ftp is able to go up to 5 or 6 MB/sec, so dependong on the type
of transfers that you are doing you will see the type of slowdown that
you are talking about.

Comment 5 Bill Chatfield 2000-01-07 15:30:59 UTC
I originally thought the machines in question were on the same physical subnet,
but after physically tracing the ethernet wires, it appears that they are not.

I suspect that this is the cause of the slowness.  Does that make sense?


Note You need to log in before you can comment on or make changes to this bug.