Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 334 - ifconfig does not run properly when rebooting
Summary: ifconfig does not run properly when rebooting
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 5.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-07 23:23 UTC by dyoung
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-25 01:38:06 UTC


Attachments (Terms of Use)

Description dyoung 1998-12-07 23:23:17 UTC
I'm trying to setup IP aliasing on Redhat5.2 which we have
just installed.  After I type in the ifconfig and route
commands and see things working well, I decided to edit the
network-scripts to save these settings so they'll come back
when I reboot.

I created ifcfg-eth0:0 in /etc/sysconfig/network-scripts

DEVICE=eth0:0
IPADDR="209.240.143.3"
NETMASK="255.255.255.0"
NETWORK=209.240.143.0
BROADCAST=209.240.143.255
ONBOOT=yes

However, after rebooting, I see this:

eth0:0    Link encap:Ethernet  HWaddr 00:A0:C9:C9:40:7A
          inet addr:209.240.143.255  Mask:255.255.255.0
          UP RUNNING  MTU:1500  Metric:1
          .......

Notice the IP address is wrong.  I also tried to manually
call "ifup eth0:0" and it does it correctly.  I tried to
use linuxconf and it doesn't work.  The problem seems to
occur when booting, the ifcfg-eth0:0 file is parsed
incorrectly.

Please let me know if you need more information.

Thanks,

David Young

Comment 1 Aleksey Nogin 1998-12-08 02:57:59 UTC
Did you try using eth0:1 instead?

Comment 2 dyoung 1998-12-08 23:47:59 UTC
Yes I have tried etho0:1.  In fact, originally, I setup eth0:0
through eth0:4 and none of them work after rebooting.  Could this
be a linuxconf problem?  We are not running the default linuxconf
that came with redhat5.2.  We have updated the linuxconf rpm to
version 1.13r5

Comment 3 Jeff Johnson 1999-03-25 01:38:59 UTC
There are a lot of changes between the "official" linuxconf
and the Red Hat linuxconf. This smells like one of those changes,
probably due to the quotes around the IPADDR.

Please reopen this bug if that is not the case.


Note You need to log in before you can comment on or make changes to this bug.