Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 333 - edquota calls /usr/bin/vi, which does not exist
Summary: edquota calls /usr/bin/vi, which does not exist
Keywords:
Status: CLOSED DUPLICATE of bug 120
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: quota
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-07 21:47 UTC by David Lawrence
Modified: 2015-03-27 19:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-15 22:53:42 UTC


Attachments (Terms of Use)

Description Derek Tattersall 1998-12-07 21:47:38 UTC
edquota calls /usr/bin/vi, instead of /bin/vi.  There is no
EDIOR variable set.

Comment 1 David Lawrence 1998-12-07 22:21:59 UTC
I could not replicate this on a test system. There is a symbolic link
in /usr/bin/ named vi that points to the vim binary. Therefore I was
not able to get it to fail on a standard 5.2 installation.

Comment 2 Derek Tattersall 1998-12-08 14:16:59 UTC
I ran edquota on two systems.  If I set the environment variable,
EDITOR, to /bin/vi, edquota would work.  With the system as
distributed, this variable is not set, and edquota fails as it assumes
that /usr/bin/vi exists, which it doesn't in a default install.

Comment 3 Derek Tattersall 1998-12-08 14:22:59 UTC
jbj appears to be the owner of the quota package.

Comment 4 Bill Nottingham 1998-12-15 22:53:59 UTC
*** This bug has been marked as a duplicate of 120 ***

Comment 5 David Tao 2009-01-06 13:37:07 UTC
yes

Comment 6 openshift-github-bot 2015-03-27 19:07:47 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/0f50aa4f547e63ca059d45cc3be0d9a1b621efa9
Issue #333, #528 - add number to builds


Note You need to log in before you can comment on or make changes to this bug.