Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3314 - tetex hyphenates "d-ifficulties"
Summary: tetex hyphenates "d-ifficulties"
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL: http://nelson.www.media.mit.edu/peopl...
Whiteboard:
: 4156 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-07 14:05 UTC by nelson
Modified: 2015-01-07 23:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-10 14:53:25 UTC


Attachments (Terms of Use)

Description nelson 1999-06-07 14:05:25 UTC
The version of tetex shipped with Redhat 6.0 seems to make
bad hyphenation choices. In particular, it is hyphenating
"difficulties" as d-ifficulties, which is definitely not
correct.

Examples are in the supplied URL.

The output of "\showhyphens{difficulties}" in both Redhat
5.2 and Redhat 6.0 is the same, "dif-fi-cul-ties". So the
core hyphenation seems to be working right. Maybe some of
the weightings are wrong? TeX has always had a hard time
hyphenating in two column mode, but the new Redhat 6.0
behaviour is unacceptable.
I am also mailing this bug report to
tetex@informatik.uni-hannover.de

Comment 1 nelson 1999-06-07 21:26:59 UTC
I got a reply from  the tetex list, from Thomas Esser. He says:
>Yes, a known problem. RedHat has used a version of a teTeX pretest
>which had a broken version of babel. This kind of problems are fixed
>in teTeX-1.0. I think that RedHat will sonn switch to that. It would
>be nice if RedHat made some update-rpm packages that at least fix the
>babel problem.


------- Additional Comments From   06/09/99 12:40 -------
tetex 1.0 is now out, which fixes this problem (and probably others).
It would be good if RH were to release errata RPMs with that.

Comment 2 Jeff Johnson 1999-06-10 14:53:59 UTC
Fixed (by upgrading) in tetex-1.0.1-2.

Comment 3 Jeff Johnson 1999-07-22 13:52:59 UTC
*** Bug 4156 has been marked as a duplicate of this bug. ***

Sometimes teTex will choose to hyphenate a word after the
first character of that word at the end of a line.

e.g.
This is an example of a line that might be hyphenated i-
ncorrectly.

I am sure this a problem with teTex, but perhaps a new
version fixes the problem, or a attribute decided at compile
time is the problem.


Note You need to log in before you can comment on or make changes to this bug.