Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3296 - "pump" not renewing DHCP leases (there was no entry for it so I used dhcpd)
Summary: "pump" not renewing DHCP leases (there was no entry for it so I used dhcpd)
Keywords:
Status: CLOSED DUPLICATE of bug 3227
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-06 07:25 UTC by Bill Bradford
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-06 15:15:36 UTC


Attachments (Terms of Use)

Description Bill Bradford 1999-06-06 07:25:56 UTC
I've got RH6 working just fine, except for one problem -
"pump".

I've installed the latest version from updates:

[root@cs2867-105 /root]# rpm -q pump
pump-0.6.7-1

and it assigns an IP address just fine via DHCP at bootup
(I'm an Austin RoadRunner cablemodem subscriber):

[root@cs2867-105 /root]# ifconfig
eth0
eth0      Link encap:Ethernet  HWaddr
00:A0:CC:3E:E0:71
          inet addr:24.28.67.225
Bcast:24.28.67.255                   Mask:255.255.255.0
          UP BROADCAST RUNNING  MTU:1500
Metric:1
          RX packets:55484 errors:0 dropped:0 overruns:0
frame:0
          TX packets:51350 errors:0 dropped:0 overruns:0
carrier:0
          collisions:1128 txqueuelen:100
          Interrupt:11 Base address:0xe800

However, it seems that the dhcp lease is *not* being renewed
- forcing me to stop/restart the network interface every
few hours, in order to either re-grab the same IP address,
or be assigned a new one.

Other strangeness:

[root@cs2867-105 /root]# pump -i eth0 -s
Operation failed.

[root@cs2867-105 /root]# pump -R
Operation failed.

[root@cs2867-105 /root]# pump -s
Operation failed.

System is an Intel Celeron 366, Abit BH6 motherboard,
17.2gig IDE HD, Netgear FA310TX (DEC Tulip chipset 10/100bt)
ethernet card, Riva TNT (AGP) video, PS/2 keyboard and
mouse.  256mb RAM.

Comment 1 Anonymous 1999-06-06 07:33:59 UTC
My behavior is similar to that experienced in bug #3227, btw.

Comment 2 Jeff Johnson 1999-06-06 15:15:59 UTC
*** This bug has been marked as a duplicate of 3227 ***


Note You need to log in before you can comment on or make changes to this bug.