Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3286 - NFS exports root filesystem
Summary: NFS exports root filesystem
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-05 17:19 UTC by jmorris
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-07 23:17:19 UTC


Attachments (Terms of Use)

Description jmorris 1999-06-05 17:19:15 UTC
When mounting a remote CD via NFS, and the CD is not
actually mounted on the server, the mount succeeds with the
server's root filesystem showing up via 'df' on the client.

The remote filesystem did not appear via 'ls', but it is
worrying that the mount succeeded at all (confirmed at in
the server logs).

The exports file contained only the cd directory.

Both systems were running RedHat6, one stock, one with a
manually compiled 2.2.9 kernel.  The problem was also
observed when the roles of the systems were swapped.

If you can't reproduce it, I can provide logs, config files,
terminal dumps etc.

Comment 1 David Lawrence 1999-06-07 23:17:59 UTC
/mnt/cdrom (unless you specified differently during the install) is
located on the root file system. It is an regular directory like any
other. If a client mounts the /mnt/cdrom directory over NFS it will
work fine regardless if anything is actually there. When the client
does a 'df' on their system, the servers root file system stats will
show up because the /mnt/cdrom directory is on the root file system.
This is not a bug therefore.


Note You need to log in before you can comment on or make changes to this bug.