Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3281 - passwd operator doesn't work?
Summary: passwd operator doesn't work?
Status: CLOSED DUPLICATE of bug 5005
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: passwd
Version: 6.0
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-06-05 14:48 UTC by Karl Berry
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 1999-09-09 13:26:34 UTC

Attachments (Terms of Use)

Description Karl Berry 1999-06-05 14:48:33 UTC
Am I going crazy?  I installed Red Hat 6.0 (`Everything'),
all was well, I logged in as root on the console, typed
passwd operator to enable a non-root account, it said
  passwd: all authentication tokens updated successfully
but /etc/passwd didn't actually change, the password was
still *.  I tried several different passwords.

I did not enable MD5 passwords or NIS+ on the new setup
screen at the end.

This is not peculiar to operator.  For example, I just tried
passwd bin (another account with a * password), used
jac:jil! for the password, and /etc/passwd didn't change
despite the success message.

Comment 1 Jeff Johnson 1999-06-05 15:12:59 UTC
Change the password field from '*' to '!!' and you will be able to
change the password.

Comment 2 theman 1999-09-09 01:17:59 UTC
This is not reasonable. No other unix does anything this stupid. Root
using passwd to change the entry should ALWAYS work, no matter the

Comment 3 Jeff Johnson 1999-09-09 13:26:59 UTC
*** This bug has been marked as a duplicate of 5005 ***

Note You need to log in before you can comment on or make changes to this bug.