Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 328 - Tripwire 1.2-1 in powertools 5.2
Summary: Tripwire 1.2-1 in powertools 5.2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: 9wm
Version: 5.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-07 15:07 UTC by ian.clark
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-13 01:12:26 UTC


Attachments (Terms of Use)

Description ian.clark 1998-12-07 15:07:32 UTC
Just downloaded and installed Tripwire from the powertools
5.2 directory. Upon installation it started running itself
in initialise mode i assume, but left no database files
anywhere.

So I ran it manually as root with -v -initialise options
it then generates the directory /etc/databases and starts
scanning the files (using the standard /etc/tw.config).

It runs for a few minutes then crashes with a segmentation
fault :-

scanning: /usr/lib/linuxconf/images/vpolicies.xpm
scanning: /usr/lib/linuxconf/images/vpopuser.xpm
scanning: /usr/lib/linuxconf/images/Aloita.gif
scanning: /usr/lib/linuxconf/images/Apua.gif
scanning: /usr/lib/linuxconf/images/Ei.gif
scanning: /usr/lib/linuxconf/images/Hyvdksy.gif
Segmentation fault

Whats going wrong?

Ian

Comment 1 David Lawrence 1998-12-09 16:06:59 UTC
I got the same behavior.  segfaulted  at the same point as reporter's
system.

Comment 2 Tim Powers 2000-01-13 01:12:59 UTC
Don't rerun the initialize! It will dump core. This same thing was happening in
the RHCE courses, I rebuilt the package without initialize and it worked *since*
they initialized the db by hand. Here is what is happening in theposktinhstall
of tripwire:

cd /var/spool/tripwire
(/usr/sbin/tripwire -initialize 2>&1 | \
/bin/mail -s "Tripwire initialization report" root ) \
&& mv databases/tw.db_* . && rm -rf databases &

Tim


Note You need to log in before you can comment on or make changes to this bug.