Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3277 - RPM upgrade and install fail due to overly aggressive errors
Summary: RPM upgrade and install fail due to overly aggressive errors
Keywords:
Status: CLOSED DUPLICATE of bug 5439
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-05 00:04 UTC by Joshua Jensen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-11-25 12:07:25 UTC


Attachments (Terms of Use)

Description Joshua Jensen 1999-06-05 00:04:35 UTC
When upgrading or installing multiple packages are
attempted,  the operation will fail if one of the specified
packages is already installed.  Example:
rpm -ivh egcs* cpp* kernel-headers* bin86*
will fail simply because one of these packages was already
installed.  RPM should simply note that a package is already
installed (or is already newer), then go on with installing
or upgrading everything else specified.  Could I write a
"foreach" loop in my shell and simply go one package at a
time?  Yes, but I shouldn't have to and this wouldn't work
for dependances anyway.  FYI:  This RPM bug did not exist
before RHL 6.0

Comment 1 maavl 1999-11-25 12:07:59 UTC
This bug is duplicated as bug 5439, which is classified as WONTFIX with the
comment "This isn't a bug, it's a feature in rpm-3.0.x.". See also bug 6182.

Comment 2 Jeff Johnson 2000-10-23 14:10:02 UTC

*** This bug has been marked as a duplicate of 5439 ***


Note You need to log in before you can comment on or make changes to this bug.