Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3259 - ucd-snmp buggy (segfault)
Summary: ucd-snmp buggy (segfault)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-04 00:36 UTC by Mario Lorenz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-12 23:34:15 UTC


Attachments (Terms of Use)

Description Mario Lorenz 1999-06-04 00:36:20 UTC
I installed the SNMP-1.8 module for perl, to collect SNMP
status information from a perl script.
Unfortunately, the whole perl dumped core after the 2nd or
3rd query. I mailed the author of the SNMP module
(gmarzot@nortelnetworks.com) about it, and his response was:

>ucd-snmp 3.6.1 has a bug. either recompile with
>ZEROLENGTH_COMMUNITY(guessing from memory) defined in
>config.h or get
>3.6.2 as soon as you can.
>
>regards, GSM

I updated to 3.6.2-pre1 (in the beta directory of
ucd-snmp.ucdavis.edu), and the problem went away. So I guess
he was right. This also proves that the problem is neither
in perl nor in SNMP-1.8 (not shipped by RedHat)

Sorry for not providing more detailed information, but thats
all I got. If you want my query script (which triggers the
bug) email me.
Mario

Comment 1 Jeff Johnson 1999-06-04 08:53:59 UTC
Could you please attach a script that exercises the problem? Thanks.

Comment 2 Mario Lorenz 1999-06-12 21:26:59 UTC
See also the changelog of ucd-snmp 3.6.2 (just announced) on
http://ucd-snmp.ucdavis.edu/NEWS.txt
You therefore just might want to go for the new version.

Comment 3 Jeff Johnson 1999-06-12 23:34:59 UTC
Fixed (by upgrading) in ucd-snmp-3.6.2-1. Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.