Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3253 - stdin, stdout, sterr in stdio.h no longer usable as initializers
Summary: stdin, stdout, sterr in stdio.h no longer usable as initializers
Keywords:
Status: CLOSED DUPLICATE of bug 3137
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-03 20:11 UTC by rshapiro
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-03 20:34:07 UTC


Attachments (Terms of Use)

Description rshapiro 1999-06-03 20:11:58 UTC
In glibc-devel-2.1.1-6 a gratuitous change to
stdio.h/libio.h was made which prevents stdin, stderr and
stdout from being used as initializers.

The code below complies on every system I've tried *except*
the latest glibc-devel-2.1.1.

#include <stdio.h>
FILE *x = stdout;

An (unnacceptable) workaround is to use
_IO_stdout.

Comment 1 Jeff Johnson 1999-06-03 20:34:59 UTC
*** This bug has been marked as a duplicate of 3137 ***


Note You need to log in before you can comment on or make changes to this bug.