Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3247 - Hard stop under heavy IDE/Network traffic
Summary: Hard stop under heavy IDE/Network traffic
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-03 18:08 UTC by Martin C. Messer
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-04 21:06:54 UTC


Attachments (Terms of Use)

Description Martin C. Messer 1999-06-03 18:08:17 UTC
Customer explains:

With heavy disk usage and net activity my machine crashes.
I'm running 6.0 on a 686, 10 Gb EIDE, I forget the ethernet
card (the machine is not local, can't check at the moment)
but the driver is the epic100.  This is definitely a serious
6.0 problem as 5.1 ran on the same hardware for around 8
months with no trouble whatsoever under extremely heavy
usage conditions.

He can reproduce this by running 'hdparm -t /dev/hda' while
ping flooding the machine.

I was not able to reproduce it. It seems similar to bug
#2938, and customer tried steeping down to 386 optimization,
though he did not remove Watchdog or APM. Same results.

Comment 1 David Lawrence 1999-06-04 21:06:59 UTC
I was unable to get this to fail on a test lab machine containing a
Cyrix MII 300. I ping flooded the machine while running the hdparm -t
/dev/hda command. It got noticable slower but never locked up.

------- Additional Comments From   06/12/99 01:43 -------
Some info got left off of my original report below.  First, another
user saw exactly the same behavior:
http://x28.deja.com/getdoc.xp?AN=484168039.1&CONTEXT=928218503.648347748&hitnum=20
I don't get a reboot, the machine just locks up.

Second, doing a hdparm -d 1/dev/hda (i.e. enabling DMA)
"solves" the problem.

Third, ifconfig shows that packets are being dropped prior
to the failure.  If I am ftp'ing a large file, the machine
locks, but the halt can be avoided if I continually do network
restarts during the transfer.

Comment 2 Alan Cox 1999-06-12 13:24:59 UTC
This is a real bug in the EPIC100 driver. It requires that interrupts
are deferred for a long time while the card receives only small
frames. The fix is in 2.2.7 or so and higher, I can provide it if
need be.


Note You need to log in before you can comment on or make changes to this bug.