Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3239 - /sbin/mount.smb handles user and passwd options wrongly
Summary: /sbin/mount.smb handles user and passwd options wrongly
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 4973 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-03 14:50 UTC by tpr
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-14 17:32:04 UTC


Attachments (Terms of Use)

Description tpr 1999-06-03 14:50:13 UTC
Mounting an smbfs filesystem from /etc/fstab, if you use the
user=wibble,passwd=hatstand options, the /sbin/mount.smb
script gets the smbmount command line wrong, putting the
-U wibble before the hatstand. Patch is:

--- /sbin/mount.smb.orig        Thu Jun  3 11:56:23 1999
+++ /sbin/mount.smb     Thu Jun  3 11:56:40 1999
@@ -39,7 +39,7 @@
 done

 if [ -n "$PASSWD" ]; then
-      exec smbmount "$1" $USER $PASSWD -c "$COMMAND"
+      exec smbmount "$1" $PASSWD $USER -c "$COMMAND"
 else
       exec smbmount "$1" -N $USER -c "$COMMAND"
 fi

Comment 1 Bill Nottingham 1999-06-14 17:32:59 UTC
fixed in latest samba release (2.0.4b-4, or so)

Comment 2 Bill Nottingham 1999-09-08 14:29:59 UTC
*** Bug 4973 has been marked as a duplicate of this bug. ***

/sbin/mount.smb places the password in the wrong place
causing the smbmount to fail.

Replace:
    exec smbmount "$1" $USER $PASSWORD -c "$COMMAND"
with
    exec smbmount "$1" $PASSWD $USER -c "$COMMAND"

thanks,
john


Note You need to log in before you can comment on or make changes to this bug.