Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3230 - rpm-3.0.1 doesn't set execute permissions on the doc directory
Summary: rpm-3.0.1 doesn't set execute permissions on the doc directory
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 4580 9279 10274 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-03 07:26 UTC by benedict
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 21:47:38 UTC


Attachments (Terms of Use)

Description benedict 1999-06-03 07:26:54 UTC
I have package rpm-shr which amongst others contains the doc
files in directory /usr/local/share/doc/rpm-shr-3.0.1/

However, the directory /usr/local/share/doc/rpm-shr-3.0.1/
is not executable, so the files end up as 'missing'.
This is new behaviour.

Comment 1 Jeff Johnson 1999-06-03 10:21:59 UTC
What platform is this on? IRIX?

Comment 2 benedict 1999-06-03 11:29:59 UTC
IRIX or Solaris alike

Comment 3 benedict 1999-06-03 14:46:59 UTC
It seems that there is something wrong with the attributes of %doc
files.  1) there is no way to influence the attributes of the doc
directory itself 2) the attributes of *all* doc files are taken from
the first file mentioned in the list - make that one executable and
the directory and all doc files will be executable ...

%files
%attr(444,benedict,sys) %doc README
%attr(0,root,staff) %doc ChangeLog

gives the following contents of the package:

dr--r--r-- benedict      sys         42 Jun 03 16:41
/usr/local/share/doc/hello-shr-1.3
-r--r--r-- benedict      sys       5664 May 23  1993
/usr/local/share/doc/hello-shr-1.3/ChangeLog
-r--r--r-- benedict      sys        790 May 20  1993
/usr/local/share/doc/hello-shr-1.3/README

whereas

%files  shr
%attr(555,benedict,sys) %doc README
%attr(0,root,staff) %doc ChangeLog

gives

dr-xr-xr-x benedict      sys         42 Jun 03 16:45
/usr/local/share/doc/hello-shr-1.3
-r-xr-xr-x benedict      sys       5664 May 23  1993
/usr/local/share/doc/hello-shr-1.3/ChangeLog
-r-xr-xr-x benedict      sys        790 May 20  1993
/usr/local/share/doc/hello-shr-1.3/README

Comment 4 Jeff Johnson 2001-01-09 16:27:25 UTC
*** Bug 10274 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2001-02-21 18:42:14 UTC
*** Bug 4580 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2001-02-21 18:43:21 UTC
Changing component.

Comment 7 Jeff Johnson 2001-02-21 18:51:11 UTC
*** Bug 9279 has been marked as a duplicate of this bug. ***

Comment 8 Bill Nottingham 2005-09-29 21:47:38 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.


Note You need to log in before you can comment on or make changes to this bug.