Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3227 - pump locking
Summary: pump locking
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
: 3296 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-03 05:52 UTC by pierre.thonne
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-03 15:46:24 UTC


Attachments (Terms of Use)

Description pierre.thonne 1999-06-03 05:52:59 UTC
Sorry to chooce the dhcpcd component because pump is not
there.

I use pump to connect to my internet ISP. I use a
cable-modem.
I use a network card connected in the slot 0 of the pcmcia
connector.
I receive well my IP address and all the other address
(DNS,...). One thing important : the lease time is very
short; only 20 minutes.

Until the lease time is finished, I can do the following
command without problem : pump --status. If the lease time
is finished (in fact the DHCP server (witch is NT I thing,
because, I had to install the new pump package)), this
command doesn't answer. A CTRL-C and I can goes futher.
If I forgot to do that blocking command and I do a shutdown
of Linux, I can't do a CTRL-C (normal, I'm shutting down!),
I have no other choice to power off the machine : bad isn't
it!

By the way, the Internet is still accessible, I can use
netscape without problem.

Pierre Thonne
Brussels

Comment 1 Jeff Johnson 1999-06-06 15:15:59 UTC
*** Bug 3296 has been marked as a duplicate of this bug. ***

I've got RH6 working just fine, except for one problem -
"pump".

I've installed the latest version from updates:

[root@cs2867-105 /root]# rpm -q pump
pump-0.6.7-1

and it assigns an IP address just fine via DHCP at bootup
(I'm an Austin RoadRunner cablemodem subscriber):

[root@cs2867-105 /root]# ifconfig
eth0
eth0      Link encap:Ethernet  HWaddr
00:A0:CC:3E:E0:71
          inet addr:24.28.67.225
Bcast:24.28.67.255                   Mask:255.255.255.0
          UP BROADCAST RUNNING  MTU:1500
Metric:1
          RX packets:55484 errors:0 dropped:0 overruns:0
frame:0
          TX packets:51350 errors:0 dropped:0 overruns:0
carrier:0
          collisions:1128 txqueuelen:100
          Interrupt:11 Base address:0xe800

However, it seems that the dhcp lease is *not* being renewed
- forcing me to stop/restart the network interface every
few hours, in order to either re-grab the same IP address,
or be assigned a new one.

Other strangeness:

[root@cs2867-105 /root]# pump -i eth0 -s
Operation failed.

[root@cs2867-105 /root]# pump -R
Operation failed.

[root@cs2867-105 /root]# pump -s
Operation failed.

System is an Intel Celeron 366, Abit BH6 motherboard,
17.2gig IDE HD, Netgear FA310TX (DEC Tulip chipset 10/100bt)
ethernet card, Riva TNT (AGP) video, PS/2 keyboard and
mouse.  256mb RAM.


------- Additional Comments From mrbill@frenzy.com  06/06/99 03:33 -------
My behavior is similar to that experienced in bug #3227, btw.

Comment 2 Erik Troan 1999-06-22 19:34:59 UTC
Have you tried the new pump from the errata? Lease renewal was
definitely broken...

Please let us know if that doesn't fix these problems.

Comment 3 pierre.thonne 1999-06-23 06:02:59 UTC
I'm using the pump package from the errata. I had to use it because
with the original one, i cannot connect to my ISP (cable-modem).
So i was using the pump-0.6.7-1.i386.rpm package when I first describe
the problem here.

Cheers,

Pierre


------- Additional Comments From   06/23/99 05:53 -------
This *is* the version from the errata, unfortunately; I applied all
relevant updates immediately after I installed the OS.
 -bill (mrbill@frenzy.com)

Comment 4 Breckin Loggins 2000-01-20 03:00:59 UTC
I've been told that the newest version of pump fixes these problems.
(ftp://ftp.redhat.com/rawhide/i386/RedHat/RPMS/)  This is version 0.7.3-2 or
something like that.  Beware that this is a "bleeding edge" release and as such
it may not be terribly stable.  Anyway, I was having the exact same problem with
pump.  At first I thought it was a problem with IP Masquerading (since I'm using
the box as a proxy server).  It took me several days of having the machine work
fine for an hour, then not connecting to the internet at all.  I couldn't ping
any public IP addresses from either the NATed hosts or the linux box itself.
When I rebooted it worked fine for about another hour.  I finally caught on when
I realized that my cable modem company's DHCP server sets a lease time of (you
guessed it) one hour.  Pump was completely locking up when it tried to renew the
DHCP address, taking the entire eth0 interface down with it.  If I killed it
(using a killall pump command) and then brought it back up it worked fine until
it had to renew again.  Also noticed that "pump -R" or "pump -R -i eth0" never
worked even after I upgraded pump to 0.7.0.  Anyway, to make a long story short
(too late, I know) I just did away with pump and went back to good 'ol dhcpcd.
It works perfectly for my purposes and it hasn't gone down since.

Comment 5 Erik Troan 2000-02-03 15:46:59 UTC
There will be a new pump (0.7.6) on ftp://people.redhat.com/ewt this afternoon,
which I believe fixes these problems. If  it does not help, please reopen this
bug.


Note You need to log in before you can comment on or make changes to this bug.