Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3226 - Sendmail 8.9.3 as shipped with Red Hat 6.0 breaks SmartList
Summary: Sendmail 8.9.3 as shipped with Red Hat 6.0 breaks SmartList
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-03 01:57 UTC by seifried
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-01 13:08:43 UTC


Attachments (Terms of Use)

Description seifried 1999-06-03 01:57:26 UTC
the smrsh command is somehow bjorked. RedHat 5.2 box
upgraded mostly to 6.0, running a contrib version of
sendmail rpm (8.9.2), SmartList works fine with it. Upgrade
d to sendmail 8.9.3 as shipped with Red Hat 6.0, SmartList
no longer works. Tried on a fresh 6.0 box, same thing. Here
is the output from /var/log/maillog:

Jun  2 19:58:28 mail sendmail[15592]: TAA15592: from=root,
size=210, class=0, pri=30210, nrcpts=1,
msgid=<199906030158.TAA15592@mail.seifried.org>,
relay=root@localhost
Jun  2 19:58:28 mail smrsh: uid 8: attempt to use
exec /etc/smrsh/flist rebar-redhat-request
Jun  2 19:58:28 mail sendmail[15594]: TAA15592:
to="|exec /etc/smrsh/flist rebar-redhat-request",
delay=00:00:00, xdelay=00:00:00, mailer=prog, stat=Service
unavailable
Jun  2 19:58:28 mail sendmail[15594]: TAA15592: TAA15594:
DSN: Service unavailable

DSN service unavailable for any SmartList list, for all
services, i.e. it won;t execute the external programs
needed by SmartList, tried the latest version of SmartList
no good either. Apart from this the sendmail that ships
with RH 6.0 works fine.

Comment 1 Jeff Johnson 1999-06-05 16:29:59 UTC
Can you try creating a symlink in /etc/smrsh to whatever flist
you are trying to execute, something like
	ln -s /usr/bin/flist /etc/smrsh/flist

Do the same for any other smartlist executables that are mentioned
in sendmail.cf ...

Comment 2 Jeff Johnson 1999-09-01 13:08:59 UTC
This problem appears fixed (i.e. create symlinks in /etc/smrsh for
mail add-on executables).


Note You need to log in before you can comment on or make changes to this bug.