Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3221 - Bad /etc/securetty on headless sparc 2
Summary: Bad /etc/securetty on headless sparc 2
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: setup
Version: 6.0
Hardware: sparc
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-02 20:46 UTC by lars
Modified: 2014-03-17 02:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-02 18:15:56 UTC


Attachments (Terms of Use)

Description lars 1999-06-02 20:46:06 UTC
After dealing with the headless install problems (#2602,
time to resolution: 25 days), and then then headless
/etc/inittab problems (#3208, still open), I'm now unable to
log in as root on the console of my headless system.

The problem is that the /etc/securetty file distributed with
RedHat 6.0 does not include ttyS0 or ttyS1.

Workaround: edit /etc/securetty.  Add "ttyS0".

Solution: Rip the keyboard and monitor off your existing
Sparc systems, run a serial cable to a PC, and try out a
complete headless install, from beginning to end.  Make sure
it works.  Release errata.

Comment 1 David Lawrence 1999-06-02 23:27:59 UTC
I have verified that /etc/securetty does not include entries for
serial consoles.
Thank you for the suggestion. It has been assigned to a developer for
further review.

Comment 2 Jeff Johnson 1999-09-02 18:15:59 UTC
We can't add ttyS[01] to /etc/securetty because dialin lines are
usually insecure. This needs to be dealt with in the installer.
I'm preserving the bug by rsolving to the REMIND state.


Note You need to log in before you can comment on or make changes to this bug.