Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3217 - bug in "RS" capability in lpd
Summary: bug in "RS" capability in lpd
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-02 19:28 UTC by mcintosh
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-02 22:58:16 UTC


Attachments (Terms of Use)

Description mcintosh 1999-06-02 19:28:20 UTC
Attempts to print to printers with the "rs" capability
turned on result in a cryptic error message that the job
could not be printed, with no explanation as to why.

The cause is a bug in printit() in lpd/printjob.c.  If the
"rs" capability is turned on, the code exits case 'P' in
pass 1 without ever setting euser[] to something reasonable.
This confuses later code that thinks it has been set.

I will post a fix once a bug number has been assigned.

------- Email Received From  Allen Mcintosh <mcintosh@research.telcordia.com> 06/02/99 15:58 -------

Comment 1 Jeff Johnson 1999-06-02 22:58:59 UTC
Fixed (by applying patch) in lpr-0.36-4. Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.