Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3208 - RedHat 6.0 provides bogus /etc/inittab for headless systems
Summary: RedHat 6.0 provides bogus /etc/inittab for headless systems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: sparc
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-02 07:13 UTC by H. Peter Anvin
Modified: 2014-03-17 02:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-12-17 21:36:55 UTC


Attachments (Terms of Use)

Description H. Peter Anvin 1999-06-02 07:13:03 UTC
While upgrading RedHat 5.2->6.0 on a headless SS20 dual
HyperSPARC, /etc/inittab is replaced with a version that
expects to use virtual consoles, and *only* virtual
consoles.  As a result, the system becomes inaccessible once
it enters multiuser mode, if the network in unavailable (as
it became for me due to a ypbind startup bug -- separate bug
report has been filed.)

RedHat 5.2 handled this flawlessly out of the box.

Comment 1 lars 1999-06-02 20:36:59 UTC
This bug still exists on the recently released images (6/2/99).

Workaround: Log in single user mode.  Edit /etc/inittab.  Add a line
that looks like this:

  t1:2345:respawn:/sbin/getty ttyS0 19200 vt100

Permanent solution: test your software *before* releasing it.  There's
not way to miss a bug like this.

Comment 2 David Lawrence 1999-06-11 19:55:59 UTC
I have verified this to be true on a sparc in our test lab.

Comment 3 Bill Nottingham 1999-06-14 17:53:59 UTC
The old inittab should be saved as inittab.rpmsave (if not, that
is definitely a bug...); the problem is, that that's a change
made to a configuration file, and we can't sanely munge config
files with RPM. AFAIK, serial consoles were never set up in
inittab by the installer...

------- Email Received From  "H. Peter Anvin" <hpa@transmeta.com> 06/14/99 15:47 -------

Comment 4 marcm 1999-06-22 15:36:59 UTC
Shouldn't that change to the inittab file be:

sc:12345:respawn:/sbin/getty cua0 9600 vt100

(almost verbatim from a 5.2 installation)

You forgot run level 1 and the "default" serial port speed is 9600.
Yeah higher is nice but the chances are that if you are installing
from a default machine the serial ports are at 9600.

Also, the virtual terminals are commented out in my 5.2 install -
should that be done too when "fixing" a 6.0 install?

Comment 5 lars 1999-06-22 15:51:59 UTC
> sc:12345:respawn:/sbin/getty cua0 9600 vt100

This is incorrect; the /dev/cua* devices have been deprecated for some
time in favor of /dev/ttyS*.

Additionally, you do *not* want to start a getty in runlevel 1 (single
user mode); Linux dumps you to a shell automatically in this runlevel,
and an attempt to start getty would just cause problems.

You are correct that the baud rate should probably be set to 9600.

Comment 6 Bill Nottingham 1999-12-17 21:36:59 UTC
This should be fixed in the 6.1 installer.


Note You need to log in before you can comment on or make changes to this bug.