Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3202 - sendmail.cf generated by linuxconf does not do user masquerading
Summary: sendmail.cf generated by linuxconf does not do user masquerading
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 2522 3930 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-02 01:01 UTC by mmclure
Modified: 2008-05-01 15:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-10 19:29:50 UTC


Attachments (Terms of Use)

Description mmclure 1999-06-02 01:01:18 UTC
Even if you set up user masquerading, it never happens
because rule 94 never calls rule 93. The fix is to change
lines 134-136 of /usr/lib/linuxconf/mailconf/rulesets.cf
from:

S94
#R$+                     $@ $>93 $1
R$* < @ *LOCAL* > $*    $: $1 < @ $j . > $2

to:

S94
R$+                     $@ $>93 $1
R$* < @ *LOCAL* > $*    $: $1 < @ $j . > $2

(i.e. uncomment line 135). I did this change and sendmail
now correctly does user masquerading.

Comment 1 mmclure 1999-06-02 19:14:59 UTC
This seems to be the same bug as 2522.

Comment 2 Dale Lovelace 1999-06-11 16:22:59 UTC
*** Bug 2522 has been marked as a duplicate of this bug. ***

Linuxconf has the ability to setup sendmail "masquerading
rules" to rewrite from addresses.  While I can't read the
sendmail.cf rules (but then again, who can!?!), my testing
shows that mail sent (w/ elm in my case) from a local
account does not get the from address rewritten.  This was
tested with both username@localhost and username@my.FQDN.

Comment 3 Derek Tattersall 1999-08-03 19:21:59 UTC
*** Bug 3930 has been marked as a duplicate of this bug. ***

Have used linuxconf to change sendmail.cf.
Have a LAN with inofficial FQDN an so I need the "Dj"
command in sendmail.cf to fake my FQDN due to ISP
requirements.  So I did changes on sendmail.cf by hand
because linuxconf did not set any "Dj" command in
sendmail.cf (which is a different issue, I know).
On next reboot, the systems stucks while
executing /etc/rc.d/rc3.d/S99linuxconf !
If you boot in "single" mode and execute S99linuxconf you
see why: S99linuxconf needs manual input because the
sendmail.cf was changed by hand!

Workaround: have renamed S99linuxconf to orig-S99linuxconf

------- Additional Comments From johnsonm@redhat.com  07/30/99 12:29 -------
Jacques, is this fixed in 1.16r1.3?  This seems to stir a faint
memory of discussion on the linuxconf list...

Comment 4 Brent Fox 2002-06-05 15:44:57 UTC
Closing because we don't ship linuxconf anymore.


Note You need to log in before you can comment on or make changes to this bug.