Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 320001 - NetworkManager always uses DHCP (KDE live CD)
Summary: NetworkManager always uses DHCP (KDE live CD)
Keywords:
Status: CLOSED DUPLICATE of bug 134886
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-05 11:42 UTC by Paul Scott
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-13 19:13:03 UTC


Attachments (Terms of Use)
typescript of steps taken to force system to use static ip address (deleted)
2007-10-05 11:42 UTC, Paul Scott
no flags Details

Description Paul Scott 2007-10-05 11:42:59 UTC
Description of problem:
I am using the KDE live CD test 3. I boot the CD and naturally get a DHCP 
address. I install the OS and during install specify a static IPv4 address 
(along with netmask, gateway, dns and hostname). I disable IPv6. After a 
successful installation, I reboot and find that after I've created a user and 
logged in, I'm still using DHCP. I run system-config-network and find it 
configured for DHCP, my static settings lost. I reconfigure it and reboot. 
After reboot, I am still using DHCP! I check /etc/sysconfig/network 
and /etc/sysconfig/network-scripts/ifcfg-eth0 and they are correctly 
configured with my static address. The /etc/resolv.conf however is using the 
DNS servers relevant to the DHCP network, not the ones I want. The 
file /etc/hosts is non-existent!! I create it with a loopback address and a 
single reference to my static address.


Version-Release number of selected component (if applicable):
nm-applet version 0.70 

How reproducible:
Every time

Steps to Reproduce:
1. Install from Live CD. Configure static address.
2. Reboot 
3. Find self still using DHCP.
  
Actual results:
IP address always provided via DHCP when NetworkManager running.

Expected results:
NetworkManager should honour the information in the /etc/sysconfig/network* 
files.

Additional info:
Shutdown NetworkManager process and restart network configures the static 
address correctly.

Comment 1 Paul Scott 2007-10-05 11:42:59 UTC
Created attachment 217261 [details]
typescript of steps taken to force system to use static ip address

Comment 2 Dan Williams 2007-11-13 19:13:03 UTC

*** This bug has been marked as a duplicate of 134886 ***


Note You need to log in before you can comment on or make changes to this bug.