Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3200 - shell read command does not behave as expected
Summary: shell read command does not behave as expected
Keywords:
Status: CLOSED DUPLICATE of bug 8894
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pdksh
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-01 21:08 UTC by ron.kyles
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-05-29 18:00:46 UTC


Attachments (Terms of Use)

Description ron.kyles 1999-06-01 21:08:11 UTC
The following script returns nulls in the read command
arguments; however if you comment out the read command, awk
will print the field variables:

#!/bin/ksh

IFS=' '

    echo "1;/usr/tistar/bin/flpnm.asc;Name;Ascending;lp_" |
\
    awk -F\; '{if(NR == tc) {printf("%s %s %s %s\n", $2, $3,
$4, $5)}}' tc=1 | \
    read file field sortorder value
    echo $file $field $sortorder $value

Comment 1 Jeff Johnson 1999-07-23 09:11:59 UTC
This is still a problem in pdksh-5.2.14-1.

Comment 2 Jeff Johnson 1999-09-02 18:09:59 UTC
The fix won't be in Red Hat 6.1. I'm preserving the bug by changing
the state to REMIND.

Comment 3 Trond Eivind Glomsrxd 2001-05-29 18:01:05 UTC

*** This bug has been marked as a duplicate of 8894 ***


Note You need to log in before you can comment on or make changes to this bug.