Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3179 - Installation of bad RPMs don't generate error return
Summary: Installation of bad RPMs don't generate error return
Keywords:
Status: CLOSED DUPLICATE of bug 26850
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-31 17:04 UTC by Steve Coile
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-30 23:28:48 UTC


Attachments (Terms of Use)

Description Steve Coile 1999-05-31 17:04:55 UTC
When attempting to "rpm -Uvh --force --nodeps" on a file
that does not contain an RPM, "rpm" returns the error
message, "error: <package> does not appear to be a RPM
package", which is correct, but the return code is zero
(0), indicating success.  The return code should be
non-zero.

Comment 1 Jeff Johnson 2001-02-21 18:26:50 UTC

*** This bug has been marked as a duplicate of 26850 ***


Note You need to log in before you can comment on or make changes to this bug.