Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3174 - xfs does not listen on TCP 7100 as documented
Summary: xfs does not listen on TCP 7100 as documented
Keywords:
Status: CLOSED DUPLICATE of bug 2759
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2514 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-31 09:04 UTC by martin
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-03 14:47:38 UTC


Attachments (Terms of Use)

Description martin 1999-05-31 09:04:28 UTC
RH 5.2 xfs listens on UNIX port 7100 AND tcp port 7100 by
default. It also accepts the -port argument to change this.

RH 6 doc says the xfs in RH 6 will listen on tcp 7100 by
default.

It does not. It ONLY listens on UNIX port -1 !!!!

(information confirmed by netstat -at and netstat -ax, the
former revealing nothing relating to xfs even when xfs is
plainly running, the latter revealing a UNIX protocol port
at: /tmp/.font-unix/fs-1)

Neither does it accept the -port argument (well, it accepts
it, but it ignores it)

Instructions on page 4 Installation guide suggest putting
"Fontpath "tcp/localhost:7100" in XF86Config. This does not
work (for the above reasons). Only

	"Fontpath "unix/:-1"

works.

Comment 1 David Lawrence 1999-06-01 22:26:59 UTC
*** Bug 2514 has been marked as a duplicate of this bug. ***

In section 1.3.0.1 (Enhanced font support) of the
installation guide (I am looking at the electronic version
from the rhl-install-guide-en-6.0-2 rpm) you give
instructions for using the new font server instead of a
conventional fontpath.
Those direction say to use "tcp/localhost:7100" in the
fontpath.  However, the version of xfs in
XFree86-xfs-3.3.3.1-49 has intentionally had TCP
functionality removed (XFree86-3.3.3.1-xfsredhat.patch
modification of file
XFree86-3.3.3.1/xc/programs/xfs/os/connection.c).  The
correct instruction would be to use "unix/:-1" in the
fontpath.

Comment 2 Jeff Johnson 1999-06-03 14:47:59 UTC
*** This bug has been marked as a duplicate of 2759 ***


Note You need to log in before you can comment on or make changes to this bug.