Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3172 - nscd on sparc (U10) causing tcpdump to dump core.
Summary: nscd on sparc (U10) causing tcpdump to dump core.
Keywords:
Status: CLOSED DUPLICATE of bug 3171
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 6.0
Hardware: sparc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-31 04:20 UTC by pfeif
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-01 21:52:04 UTC


Attachments (Terms of Use)

Description pfeif 1999-05-31 04:20:00 UTC
Here's an strace of tcpdump with nscd running:

[root@mycroft /root]# strace /usr/sbin/tcpdump -i eth0 \
host cais
execve("/usr/sbin/tcpdump", ["/usr/sbin/tcpdump", "-i",
"eth0", "host", "cais"], [/* 21 vars */]) = 0
brk(0)                                  = 0xda87c
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such
file or directory
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=19057, ...}) = 0
mmap(0, 19057, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7001a000
close(3)                                = 0
open("/lib/libc.so.6", O_RDONLY)        = 3
fstat(3, {st_mode=S_IFREG|0755, st_size=4237650, ...}) = 0
read(3, "\177ELF\1\2\1\0\0\0\0\0\0\0\0\0\0"..., 8192) = 8192
mmap(0, 1065572, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) =
0x7002a000
mprotect(0x70112000, 115300, PROT_NONE) = 0
mmap(0x7011a000, 65536, PROT_READ|PROT_WRITE|PROT_EXEC,
MAP_PRIVATE|MAP_FIXED, 3, 0xe0000) = 0x7011a000
mmap(0x7012a000, 16996, PROT_READ|PROT_WRITE|PROT_EXEC,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x7012a000
close(3)                                = 0
munmap(0x7001a000, 19057)               = 0
personality(PER_LINUX)                  = 0
getpid()                                = 5144
time(NULL)                              = 928124111
getpagesize()                           = 0x2000
brk(0)                                  = 0xda87c
brk(0xda8a4)                            = 0xda8a4
brk(0xdc000)                            = 0xdc000
open("/etc/localtime", O_RDONLY)        = 3
read(3, "TZif\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 44) = 44
read(3, "\234\275\1\360\234\344d\300\236\270"..., 920) = 920
read(3, "\0\1\0\1\0\1\0\1\0\1\0\1\0\1\0\1"..., 230) = 230
fstat(3, {st_mode=S_IFREG|0644, st_size=1218, ...}) = 0
mmap(0, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7001a000
read(3, "\377\377\307\300\1\0\377\377\271"..., 8192) = 24
close(3)                                = 0
munmap(0x7001a000, 8192)                = 0
socket(PF_INET, SOCK_PACKET, 0x3 /* IPPROTO_??? */) = 3
bind(3, {sin_family=AF_INET, sin_port=htons(25972),
sin_addr=inet_addr("104.48.0.0")}, 16) = 0
ioctl(3, SIOCGIFHWADDR, 0xeffffad8)     = 0
ioctl(3, SIOCGIFMTU, 0xeffffad8)        = 0
ioctl(3, SIOCGIFFLAGS, 0xeffffad8)      = 0
ioctl(3, SIOCSIFFLAGS, 0xeffffad8)      = 0
socket(PF_INET, SOCK_DGRAM, IPPROTO_IP) = 4
ioctl(4, SIOCGIFADDR, 0xeffffad8)       = 0
ioctl(4, SIOCGIFNETMASK, 0xeffffad8)    = 0
close(4)                                = 0
getuid()                                = 0
setuid(0)                               = 0
brk(0xe2000)                            = 0xe2000
ioctl(0, TCGETS, {B38400 opost isig icanon echo ...}) = 0
gettimeofday({928124111, 57304}, NULL)  = 0
getpid()                                = 5144
open("/etc/resolv.conf", O_RDONLY)      = 4
fstat(4, {st_mode=S_IFREG|0644, st_size=71, ...}) = 0
mmap(0, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7001a000
read(4, "search dsm.space.gc.ca\nnameserv"..., 8192) = 71
read(4, "", 8192)                       = 0
close(4)                                = 0
munmap(0x7001a000, 8192)                = 0
socket(PF_UNIX, SOCK_STREAM, 0)         = 4
connect(4, {sun_family=AF_UNIX,
sun_path="/var/run/.nscd_socket"}, 110) = 0
write(4, "\0\0\0\2\0\0\0\4\0\0\0\5", 12) = 12
write(4, "cais\0", 5)                   = 5
read(4, "\0\0\0\0\0\0\0\1\0\0\0\25\0\0\0\0"..., 32) = 32
readv(4, [{"cais.dsm.space.gc.ca\0", 21}, {"", 0},
{"\n\24J\327", 4}, {"\0\0\0\0\0\0\0\0\0\0\377\377\n\24"...,
16}], 4) = 41
read(4, NULL, 0)                        = 0
close(4)                                = 0
--- SIGBUS (Bus error) ---
+++ killed by SIGBUS +++
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Without nscd it works fine:

[root@mycroft /root]# /etc/rc.d/init.d/nscd stop
Stopping Name Switch Cache Daemon: nscd
[root@mycroft /root]#  /usr/sbin/tcpdump -i eth0 host cais
tcpdump: listening on eth0
00:17:48.456653 mycroft.dsm.space.gc.ca.1048 >
cais.dsm.space.gc.ca.domain: 62112+ (38)
00:17:48.457028 cais.dsm.space.gc.ca.domain >
mycroft.dsm.space.gc.ca.1048: 62112* 1/1/1 (99) (DF)
[SNIP]

6 packets received by filter
0 packets dropped by kernel
[root@mycroft /root]#

Comment 1 David Lawrence 1999-06-01 21:52:59 UTC
*** This bug has been marked as a duplicate of 3171 ***


Note You need to log in before you can comment on or make changes to this bug.