Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3164 - slocate hangs on mounted VFAT partitions
Summary: slocate hangs on mounted VFAT partitions
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: crontabs
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
: 3280 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-30 22:04 UTC by Adam Spiers
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2001-04-10 22:04:18 UTC


Attachments (Terms of Use)

Description Adam Spiers 1999-05-30 22:04:33 UTC
slocate hangs on mounted VFAT partitions.
Reproduce via:

1. mount a VFAT partition
2. run /usr/bin/slocate -u -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net,/proc" -v
   (as typically run from /etc/cron.daily, but with an
   extra -v option to see what's going on)
3. watch it get stuck and eat CPU when it encounters the
   VFAT partition

Please note!
The Redhat 6.0 Bugzilla is missing the slocate component,
preventing me from logging this properly.  I suspect that
many of the RPMs added to Redhat since 5.2 (the
enlightenment RPMs are another example) are missing from
this Bugzilla config.  I will submit this problem separately
...

Comment 1 Jeff Johnson 1999-06-01 19:23:59 UTC
Fixed (by excluding vfat in cron.daily) in slocate-1.6-1.

Comment 2 Jeff Johnson 1999-06-05 16:01:59 UTC
*** Bug 3280 has been marked as a duplicate of this bug. ***

slocate launched from cron or from commandline hangs
with vfat filesystems mounted.

Comment 3 Bill Nottingham 1999-06-14 18:42:59 UTC
Can you update to the latest slocate version and try
it *without* excluding VFAT partitions?

Comment 4 Bill Nottingham 1999-06-15 14:45:59 UTC
Moreover, I can't reproduce this on a VFAT partition here,
with slocate-1.4

Comment 5 Bill Nottingham 1999-06-16 16:59:59 UTC
If you can get it stuck, what does an strace
of the slocate process say?

Comment 6 Adam Spiers 1999-06-19 17:48:59 UTC
Damn, I can't reproduce it any more.  I've reincluded /mnt/C
in the slocate cron job in the hope that it will stop working;
if so, I'll get you an strace.

Comment 7 Jeff Johnson 1999-07-01 15:10:59 UTC
This bug appears to be resolved. Please reopen if I'm wrong.


Note You need to log in before you can comment on or make changes to this bug.