Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 314331 - X lockup on kernels after kernel-2.6.20-1.2962
Summary: X lockup on kernels after kernel-2.6.20-1.2962
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2007-10-01 18:11 UTC by John Ellson
Modified: 2008-01-08 17:53 UTC (History)
1 user (show)

Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-08 17:53:39 UTC


Attachments (Terms of Use)
/va/r/log/Xorg.0.log showing lockup (deleted)
2007-10-01 18:11 UTC, John Ellson
no flags Details
/var.lof/Xorg.0.log from normal startup on older kernel-2.6.20-1.2962 (deleted)
2007-10-01 18:13 UTC, John Ellson
no flags Details
output from lspci (deleted)
2007-10-01 18:14 UTC, John Ellson
no flags Details
/etc/X11/xorg.conf (deleted)
2007-10-01 18:15 UTC, John Ellson
no flags Details
/etc/X11/xorg.conf with 16bpp depth which breaks kernel (deleted)
2007-10-09 14:29 UTC, John Ellson
no flags Details
Diff of working and broken log files (deleted)
2007-10-09 20:53 UTC, Chuck Ebbert
no flags Details

Description John Ellson 2007-10-01 18:11:49 UTC
Description of problem:
Booting kernel later than kernel-2.6.20-1.2962 results in X11 display lockup,
followed by a total sytem lockup requiring hard reboot.

Version-Release number of selected component (if applicable):
kernel-2.6.22.7-57.fc6.i686

How reproducible:
100%

Steps to Reproduce:
1.reboot with kernel-2.6.22.7-57.fc6.i686
2.
3.
  
Actual results:
Display locks up with vertical color bars on left and right sides.
Total system lockup.

Expected results:
Normal display as with older kernel-2.6.20-1.2962.fc6.i686

Additional info:

Comment 1 John Ellson 2007-10-01 18:11:49 UTC
Created attachment 212571 [details]
/va/r/log/Xorg.0.log showing lockup

Comment 2 John Ellson 2007-10-01 18:13:12 UTC
Created attachment 212581 [details]
/var.lof/Xorg.0.log from normal startup on older kernel-2.6.20-1.2962

Comment 3 John Ellson 2007-10-01 18:14:19 UTC
Created attachment 212591 [details]
output from lspci

Comment 4 John Ellson 2007-10-01 18:15:19 UTC
Created attachment 212601 [details]
/etc/X11/xorg.conf

Comment 5 John Ellson 2007-10-09 14:28:12 UTC
Still broken in kernel-2.6.22.9-61.fc6.i686

The problem seems to be that 16bpp support is broken in recent kernels.   I was
using 16bpp to get 1600x1200 resolution with the limited graphics memory in this
card.

The next attached /etc/X11/xorg.conf fails at 1400x1250, but works if depth is
changed to 24 (2 places).

Comment 6 John Ellson 2007-10-09 14:29:36 UTC
Created attachment 221301 [details]
/etc/X11/xorg.conf with 16bpp depth which breaks kernel

Comment 7 Chuck Ebbert 2007-10-09 20:53:15 UTC
Created attachment 221761 [details]
Diff of working and broken log files

Comment 8 Jon Stanley 2008-01-08 01:47:56 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 9 John Ellson 2008-01-08 02:24:50 UTC
I'm still using kernel-2.6.22.9-61.fc6.i686 on that otherwise vanilla F8 box,
because that is still the last one that works for me.  I think I'm having other
problems than the one described here with the latest F8 kernels, but I'll have
to be physically there to retest and be able to recover. I'll update this when I
go in to work tomorrow.

Comment 10 John Ellson 2008-01-08 17:39:18 UTC
OK, finally, I have kernel-2.6.23.9-85.fc8.i686 running on this box with a fresh
X11 config with "thousands of colors" and 1600x1200 resolution.  

The new kernel was dying in grub with "No setup signature found..." because
of some old crud from 2002 in /boot.  I spend the morning with a rescue boot
and, ultimately, "grub-install /dev/sda" to get it to work again.    An
incremental upgrade at some point wasn't handled very well.

Anyway, the original graphics problem seems to have gone, so this bug can be
closed.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.