Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3116 - Setting $INPUTRC is harmful - /etc/inputrc is BAD
Summary: Setting $INPUTRC is harmful - /etc/inputrc is BAD
Keywords:
Status: CLOSED DUPLICATE of bug 2738
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-28 12:34 UTC by torben
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-28 20:27:28 UTC


Attachments (Terms of Use)

Description torben 1999-05-28 12:34:09 UTC
After upgrading to redhat-6.0, the user's .inputrc files
stopped working.

Investigatigation revealed that INPUTRC is set in
/etc/profile, pointing to /etc/inputrc.

Worse, it assumes everybody want's editing-mode-emacs.
Even "Fixing it" by submitting "set -o vi" does not work,
because the key bindings in /etc/inputrc break
vi-editing-mode.

Most people know vi, not emacs. So it is a mystery to me why
you want to force emacs mode in bash, and even prevent the
bash builtin 'set -o vi' to work.

Comment 1 Dale Lovelace 1999-05-28 20:27:59 UTC
*** This bug has been marked as a duplicate of 2738 ***


Note You need to log in before you can comment on or make changes to this bug.