Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3080 - gdm doesn't write utmp entry like xdm does...
Summary: gdm doesn't write utmp entry like xdm does...
Keywords:
Status: CLOSED DUPLICATE of bug 2614
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gdm
Version: 6.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Mason
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-27 01:36 UTC by Joseph Malicki
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-31 19:08:07 UTC


Attachments (Terms of Use)

Description Joseph Malicki 1999-05-27 01:36:33 UTC
xdm writes utmp/wtmp entries during login/logout in
GiveConsole and TakeConsole like so:

GiveConsole:/usr/X11R6/bin/sessreg  -a -w "/var/log/wtmp" -u
"/var/run/utmp" \
TakeConsole:/usr/X11R6/bin/sessreg -d -w "/var/log/wtmp" -u
"/var/run/utmp" \

But gdm doesn't, so when I log in via gdm, I can see "0
users".. this isn't a really big deal, but is it possible
that it could be fixed to track logins/logouts via gdm?

Comment 1 Joseph Malicki 1999-05-27 02:59:59 UTC
This can be fixed by the following, could you please include in next
release?

mkdir /etc/X11/gdm/{Pre,Post}Session
cp /etc/X11/xdm/GiveConsole /etc/X11/gdm/PreSession/Default
cp /etc/X11/xdm/TakeConsole /etc/X11/gdm/PostSession/Default

Comment 2 Jay Turner 1999-05-27 14:34:59 UTC
This issue has been forwarded to a developer for further review

Comment 3 Michael K. Johnson 1999-07-12 20:57:59 UTC
Added mkp to CC so that he can evaluate this change for the next
version of gdm.

Comment 4 Elliot Lee 1999-08-31 19:08:59 UTC
*** This bug has been marked as a duplicate of 2614 ***


Note You need to log in before you can comment on or make changes to this bug.