Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3079 - Ip aliasing/masquerading does not work
Summary: Ip aliasing/masquerading does not work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: macutils
Version: 6.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-27 01:04 UTC by cwilliams
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-28 19:01:47 UTC


Attachments (Terms of Use)

Description cwilliams 1999-05-27 01:04:25 UTC
I wished to report that IP aliasing, or multi-homing does
not work properly with redhat 6.0.  For instance please see
the scenario below.
ifconfig eth0 inet 10.5.4.254 netmask 255.255.255.0
broadcast
10.5.4.255 <ret>
route add -net 10.5.4.0 netmask 255.255.255.0 eth0
produces an address for a single "user" on my NIC card.
However when I attempt to alias this NIC card as such...
ifconfig eth0:2 inet 10.10.10.10 netmask 255.255.255.0
broadcast
10.10.10.255 <ret>
route add -net 10.10.10.0 netmask 255.255.255.0 eth0:2
I get another logical device that is not annotated  eth0:2
when I type netstat -rn.  yet the configured interface is
eth0:2 when I type ifconfig.  All preivious version of
Redhat have this capability and it is very important to my
work.
The same result is produced when I use the config scripts
located in /etc/sysconfig/network-scripts.  ifconfig from my
box:
eth5      Link encap:Ethernet  HWaddr 00:40:05:41:4B:17
          inet addr:10.5.4.254  Bcast:10.5.4.255
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0
carrier:0
          collisions:0 txqueuelen:100
          Interrupt:11 Base address:0xec00

eth5:0    Link encap:Ethernet  HWaddr 00:40:05:41:4B:17
          inet addr:10.10.10.10  Bcast:10.10.10.255
Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
Interrupt:11 Base address:0xec00

netstat -rn
10.5.0.254      0.0.0.0         255.255.255.255 UH        0
0
0 eth1
10.5.2.254      0.0.0.0         255.255.255.255 UH        0
0
0 eth3
10.5.4.254      0.0.0.0         255.255.255.255 UH        0
0
0 eth5
10.5.1.254      0.0.0.0         255.255.255.255 UH        0
0
0 eth2
10.5.3.254      0.0.0.0         255.255.255.255 UH        0
0
0 eth4
206.71.183.0    0.0.0.0         255.255.255.224 U         0
0
0 eth0
10.5.4.0        0.0.0.0         255.255.255.0   U         0
0
0 eth5
10.5.1.0        0.0.0.0         255.255.255.0   U         0
0
0 eth2
10.10.10.0      0.0.0.0         255.255.255.0   U         0
0
0 eth5
10.5.0.0        0.0.0.0         255.255.255.0   U         0
0
0 eth1
10.5.3.0        0.0.0.0         255.255.255.0   U         0
0
0 eth4
10.5.2.0        0.0.0.0         255.255.255.0   U         0
0
0 eth3
127.0.0.0       0.0.0.0         255.0.0.0       U         0
0
0 lo

Comment 1 Jay Turner 1999-05-27 14:52:59 UTC
Behavior confirmed in test lab.  Appears as if netstat is simply
truncating the interface designation, as everything functions
correctly with the aliased interface.

Comment 2 Michael K. Johnson 1999-08-28 19:01:59 UTC
This is directly caused by a kernel change -- check the contents of
/proc/net/routes.  It's not something that we can unilaterally change.
It's not precisely a bug; it's a change in behaviour.  Sorry that
it is causing you trouble...


Note You need to log in before you can comment on or make changes to this bug.