Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3072 - Kernel module built for SMP kernel does not have correct version.
Summary: Kernel module built for SMP kernel does not have correct version.
Keywords:
Status: CLOSED DUPLICATE of bug 3151
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-26 17:13 UTC by gungnir
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-08 22:23:01 UTC


Attachments (Terms of Use)

Description gungnir 1999-05-26 17:13:46 UTC
Building Daryll Strauss' 3dfx.o device on for an SMP kernel
(2.2.5-15smp) creates a 3dfx.o with the version 2.2.5-15.

I had previously configured the kernel with SMP.

I got the device to build with the correct version by
manually editing /usr/src/linux/include/linux/version.h
and adding the 'smp' postfix to UTS_RELEASE.

Comment 1 Jay Turner 1999-05-26 17:51:59 UTC
I have seen this discrepancy in the test lab, but have not had trouble
building modules.  I am forwarding this issue to a developer for
further review.

Comment 2 Jeff Johnson 1999-06-08 22:23:59 UTC
*** This bug has been marked as a duplicate of 3151 ***


Note You need to log in before you can comment on or make changes to this bug.