Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 306841 - rpm-spec-mode unable to add changelog entries
Summary: rpm-spec-mode unable to add changelog entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Coldwell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-09-26 12:32 UTC by Jeremy Katz
Modified: 2007-12-07 21:32 UTC (History)
5 users (show)

Fixed In Version: 22.1-8.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-17 05:33:11 UTC


Attachments (Terms of Use)
xemacs compat patch (deleted)
2007-11-01 19:25 UTC, Chip Coldwell
no flags Details | Diff

Description Jeremy Katz 2007-09-26 12:32:17 UTC
rpm-spec-mode seems to have lost the ability to add changelog entries in
rawhide.  After doing rpm-add-change-log-entry and typing the entry, you get the
message
  rpm-spec-field-value: Invalid function: ignore-errors
and your changelog entry is lost

Comment 1 Ville Skyttä 2007-10-02 16:23:38 UTC
I think XEmacs CVS is nowadays the most advanced upstream for this mode - I
(think I) fixed this problem there for GNU Emacs some time ago:

http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/prog-modes/rpm-spec-mode.el.diff?r1=1.23&r2=1.24&diff_format=u

Comment 2 Jens Petersen 2007-10-15 05:55:00 UTC
Re-bytecompiling rpm-spec-mode.el by hand seems to fix the problem for me.
Not sure why it is broken or if rpm-spec-mode.el should require cl-macs at
compile time.

But it would probably be a good idea to update the latest version from XEmacs.

Comment 3 Jeremy Katz 2007-10-24 20:04:44 UTC
Thanks for the pointer Ville -- updated to the latest version and it does seem
to be fixed with it.  Building that now 

Comment 4 James Ralston 2007-11-01 19:18:43 UTC
I updated to revision 1.24 of rpm-spec-mode.el from cvs.xemacs.org.  For me, it
also breaks, but in a different manner:

Symbol's function definition is void: user-mail-address

(I have user-mail-address set to my email address in my ~/.emacs file.)

Jeremy, I'd like to test the new RPMs you're building, to see if the problem is
fixed there (as you believe it is).  Any progress on making those available in
updates-testing?

Comment 5 Chip Coldwell 2007-11-01 19:25:13 UTC
(In reply to comment #4)
> I updated to revision 1.24 of rpm-spec-mode.el from cvs.xemacs.org.  For me, it
> also breaks, but in a different manner:
> 
> Symbol's function definition is void: user-mail-address

You also need the patch:

rpm-spec-mode.el-0.14-xemacs-compat.patch

in the .src.rpm.  Attached to this BZ.

Chip


Comment 6 Chip Coldwell 2007-11-01 19:25:42 UTC
Created attachment 246021 [details]
xemacs compat patch

Comment 7 Ville Skyttä 2007-11-01 20:04:00 UTC
That patch looks partially obsolete.  The latest rpm-spec-mode.el no longer uses
"ignore-errors" so it can be dropped.  Also, Emacs 22 has
"define-obsolete-variable-alias" so it can be dropped too.

The user-mail-address thing is a real issue for GNU Emacs though, I just
committed a fix for it:
http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/prog-modes/rpm-spec-mode.el.diff?r1=1.24&r2=1.25&diff_format=u

Comment 8 Chip Coldwell 2007-11-01 20:17:29 UTC
(In reply to comment #7)
> That patch looks partially obsolete.  The latest rpm-spec-mode.el no longer uses
> "ignore-errors" so it can be dropped.  Also, Emacs 22 has
> "define-obsolete-variable-alias" so it can be dropped too.
> 
> The user-mail-address thing is a real issue for GNU Emacs though, I just
> committed a fix for it:
>
http://cvs.xemacs.org/viewcvs.cgi/XEmacs/packages/xemacs-packages/prog-modes/rpm-spec-mode.el.diff?r1=1.24&r2=1.25&diff_format=u

IIUC, with this version of rpm-spec-mode we can drop the patch entirely, right?

Chip



Comment 9 James Ralston 2007-11-01 20:22:44 UTC
I just tested revision 1.25 of rpm-spec-mode.el (as-is from from cvs.xemacs.org)
with emacs-22.1-4.fc7, and rpm-add-change-log-entry works fine.  I haven't seen
any other problems so far...

Comment 10 Ville Skyttä 2007-11-01 20:36:02 UTC
(In reply to comment #8)

> IIUC, with this version of rpm-spec-mode we can drop the patch entirely, right?

Right, unless I missed something else - I don't use rpm-spec-mode with GNU Emacs
that often.

Comment 11 Fedora Update System 2007-11-08 05:59:13 UTC
emacs-22.1-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs'

Comment 12 Fedora Update System 2007-11-09 23:46:27 UTC
emacs-22.1-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs'

Comment 13 Fedora Update System 2007-11-17 05:33:06 UTC
emacs-22.1-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2007-11-17 05:34:28 UTC
emacs-22.1-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2007-12-07 21:32:56 UTC
emacs-22.1-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update emacs'


Note You need to log in before you can comment on or make changes to this bug.