Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3054 - "can't locate module <netdev>:xx" kernel warnings
Summary: "can't locate module <netdev>:xx" kernel warnings
Keywords:
Status: CLOSED DUPLICATE of bug 3588
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-26 00:32 UTC by Adam Spiers
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-21 20:26:57 UTC


Attachments (Terms of Use)

Description Adam Spiers 1999-05-26 00:32:10 UTC
"can't locate module <netdev>:xx" kernel warnings are
produced when /etc/sysconfig/network-scripts/ifup-post
runs ifup-aliases (where <netdev> is typically lo or eth0
and xx is a number from 0 to 49).

Suggested fix: change line 20 of ifup-post to

if [ "$ISALIAS" = "yes" ] ; then

(please check that this is correct though!)

Comment 1 Jay Turner 1999-05-26 15:17:59 UTC
This issue has been forwarded to a developer for further review.

Comment 2 Adam Spiers 1999-05-27 00:07:59 UTC
These warnings are being generated from other startup scripts
too.  I haven't figured out which ones yet, but hopefully if
I never do, someone who knows more about initscripts than me
will know where else they're coming from.

Comment 3 Adam Spiers 1999-06-03 01:26:59 UTC
I've finally figured out where else these warnings are coming
from, and it's whenever

  linuxconf --hint netdev

gets run.  I looked at the linuxconf code, and thought about it,
and maybe it is actually doing the right thing, in which case
presumably the only fix is to add things like

alias lo:* off
alias eth0:* off

to /etc/conf.modules.  Or maybe linuxconf should do this itself?

Comment 4 Bill Nottingham 1999-06-21 20:26:59 UTC
*** This bug has been marked as a duplicate of 3588 ***


Note You need to log in before you can comment on or make changes to this bug.