Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3033 - quota tools go into "uninterruptible sleep" during disk operations
Summary: quota tools go into "uninterruptible sleep" during disk operations
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-25 10:30 UTC by torsten.naumann
Modified: 2008-08-01 16:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description torsten.naumann 1999-05-25 10:30:40 UTC
If I do "cp somewhta somewhere" an at the same time I run
repquota and/or quotacheck the quota tools go into sate "D"
(uninterruptible  sleep).

I've tried it on variuos hardware platforms (i386 with
different scsi and ide adaptors).

On the kernel-list comes a patch for 2.2.6 that solves this
problem but it isn't official. Here is the header of this
posting:

List:     linux-kernel
Subject:  Re: sync problem in 2.2.5
From:     Jan Kara <jack@atrey.karlin.mff.cuni.cz>
Date:     1999-04-20 22:15:58

It occurs in RedHat Linux 5.2 and 6.0.

In the official Debian 2.1 Linux Dist. this error occurs
not.

Comment 1 Alan Cox 1999-06-12 16:40:59 UTC
The patch is mostly good. Jan has posted a couple of other updates
since. It doesn't fix the SMP case apparently.

Comment 2 Jay Turner 1999-06-28 15:36:59 UTC
This issue has been forwarded to a developer for further action.

Comment 3 Jeff Johnson 1999-08-31 17:34:59 UTC
Christian, this problem is not fixed in kernel-2.2.12-3.


Note You need to log in before you can comment on or make changes to this bug.