Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3030 - smbmount i/o error
Summary: smbmount i/o error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: distribution
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-25 09:36 UTC by aina
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-01 20:50:15 UTC


Attachments (Terms of Use)

Description aina 1999-05-25 09:36:03 UTC
Standard installation of RedHat 6.0 with the samba-2.0.3-8
package. I have recompiled the kernel (2.2.5), the only
change from the standard config in the kernel-src-rpm is
that the bug workaround for samba/win95 is disabled.

The problem occurs when a shared volume on a Windows NT 4.0
(SR5) server is mounted. I run this command as root:

smbmount [share-name] [passwd] -U [username] -c 'mount
/home/ksweb -u 100'

The volume is mounted, and it works fine. After some time,
the connection "breaks" and the following problems occur:

1. When I try to "ls" the /home/ksweb directory I get the
following error: "ls: .: Input/output error"

2. The ksweb directory does not show up on a "ls /home", but
I can do a "cd /home/ksweb" without any problem.

3. When I try a smbumount I get the same error as in (1)

4. I have not succeded in unmounting with umount, I get the
"device busy" error, although the device is not busy.

Remounting the share with smbmount to another mount-point
works fine.

After a reboot everything works OK, and the problem in (2)
also disappears.

The problem is recurring, and I am experiencing it on at
least two RedHat installations.

Comment 1 Bill Nottingham 1999-05-25 14:47:59 UTC
did the NT server reboot in the time frame? If so, the connection
will break, and there hasn't yet been a fix for that.

OK, you did say you were using samba-2.0.3, and win95-workaround
was disabled, as both of those could cause problems.

There have been some reports on linux-kernel of this.

One thing you can try is to run something like this in the
background:

#!/bin/sh
while : ; do
  {
    df --sync --type=smbfs >> /dev/null;
    sleep 123;
  };
done

Admittedly, it's a hack, but it should keep the connection open.

Comment 2 Bill Nottingham 1999-07-01 20:50:59 UTC
closed due to lack of response.


Note You need to log in before you can comment on or make changes to this bug.