Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3022 - Cannot upgrade to 6.0 from local disk
Summary: Cannot upgrade to 6.0 from local disk
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-25 02:06 UTC by rbrown
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-25 13:54:53 UTC


Attachments (Terms of Use)

Description rbrown 1999-05-25 02:06:49 UTC
I DL'ed RH 6.0.  My RH 5.2 setup had
/dev/hda5 as /
/dev/hda7 as /u1
and the RH6.0 directory was /u1/public/ul/redhat-6.0/i386.
I first used this directory to successfully NFS-install
a 2nd machine on my home lan.

When I attempted to use this directory to install on the
machine which contains those files (i.e. a local install,
not over NFS), the following stuff happened:
it found the directory & ran the 2nd stage install OK.
it found the packages and asked me if I wanted to confirm
the individual packages OK.
I spent a few minutes adding some packages to those which
had been automatically selected OK.
It then told me about the future /tmp/install.log OK.
(so far so good)
It then gave an error message about a symlink failure.
But crap, wouldn't you know it, I didn't write it down.
But the Alt-f3 console had some messages like:
"filesystem already mounted, making symbolic link", and
"/mnt/u1: file exists".  (not exact quotes, sorry).

Second [related] bug:
After this error occurs, all the /dev/hda* filesystems get
unmounted and any "Retry" or "Previous" or "Menu" things
I tried resulted in a "text mode popup":
"Unable to rebuild RPM database: Perhaps the disk is full?"
(again, not exact quote).

Anyway, I had to copy the entire directory to my 2nd
machine and use the NFS install diskette instead.  Good
thing I got tons of space!

Perhaps inappropriate here, but nice job all around on 6.0.

		-rb

Comment 1 Bill Nottingham 1999-05-25 13:54:59 UTC
*** This bug has been marked as a duplicate of 2504 ***


Note You need to log in before you can comment on or make changes to this bug.