Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3021 - doit.c:setupXfree() forgets to close RPM database (kickstart)
Summary: doit.c:setupXfree() forgets to close RPM database (kickstart)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-25 01:03 UTC by pahe+redhat-bugzilla
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-07-07 16:26:11 UTC


Attachments (Terms of Use)

Description pahe+redhat-bugzilla 1999-05-25 01:03:04 UTC
In the file misc/src/install/doit.c the function will return
without closing the RPM database if Xconfigurator is not
installed.

This is a problem as the installation process continues, but
it is impossible to install RPMS in a kickstart post script.

WORKAROUND: make sure that Xconfigurator is installed

FIX:  close RPM database before returning from setupXfree()

Comment 1 Jay Turner 1999-07-07 16:26:59 UTC
*** This bug has been marked as a duplicate of 2649 ***


Note You need to log in before you can comment on or make changes to this bug.