Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3012 - dhcpcd/pump overwrites /etc/resolv.conf
Summary: dhcpcd/pump overwrites /etc/resolv.conf
Keywords:
Status: CLOSED DUPLICATE of bug 2790
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-24 19:35 UTC by magill
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-29 15:35:58 UTC


Attachments (Terms of Use)

Description magill 1999-05-24 19:35:49 UTC
I have a linux box with two interfaces and a ppp
connection.  I routinely connect to a commercial intranet
via ppp.  I have a local net for which I have a static
(private) IP address.  I am also connected to RoadRunner
which requires DHCP nic configuration.  Roadrunner and the
ppp intranet both use split DNS configurations, i.e. DNS
resolution from the root down will not yield correct
information for inside these intranets.  In addition, I have
a private network.  To handle this I configure a local
nameserver which is a secondary to the ppp intranet servers,
and forwards to the Roadrunner servers.

  dhcpcd and pump both overwrite /etc/resolv.conf directly
from the binaries which prevents me from disabling the
behavior.  dhcpcd at least uses /etc/dhcpcd/resolv.conf
whereas pump does not.  They should allow this behavior to
be suppressed.

Comment 1 Bill Nottingham 1999-05-24 19:44:59 UTC
chattr +i /etc/resolv.conf. :)

Comment 2 Jeff Johnson 1999-05-29 15:35:59 UTC
*** This bug has been marked as a duplicate of 2790 ***


Note You need to log in before you can comment on or make changes to this bug.