Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3009 - Kernel appears to panic when shutting down.
Summary: Kernel appears to panic when shutting down.
Keywords:
Status: CLOSED DUPLICATE of bug 3100
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-24 17:50 UTC by Chaim Frenkel
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-05 17:50:56 UTC


Attachments (Terms of Use)

Description Chaim Frenkel 1999-05-24 17:50:30 UTC
A strange screen appears just before the system shuts down.
This appears to be a dump of registers and/or memory.

If someone would tell me how to capture this (it seems to
be more than one screen full.) I will be happy to pass it
on.

This is an HP Series 4 5/133 with 48MB of memory.

The output of first few lines of dmesg.

Linux version 2.2.5-15 (root@porky.devel.redhat.com) (gcc
version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)) #1
Mon Apr 19 22:21:09 EDT 1999
Detected 132633208 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 52.84 BogoMIPS
Memory: 46920k/49152k available (996k kernel code, 412k
reserved, 764k data, 60k init)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium 75 - 200 stepping 0b
Checking 386/387 coupling... OK, FPU using exception 16
error reporting.
Checking 'hlt' instruction... OK.
Intel Pentium with F0 0F bug - workaround enabled.
POSIX conformance testing by UNIFIX
PCI: PCI BIOS revision 2.10 entry at 0xf70dc

Comment 1 Jay Turner 1999-05-24 18:23:59 UTC
Really need more information about this in order to determine what is
happening with the system.  Please try to post the dump that you are
getting.

Comment 2 Andrew Dodd 1999-05-24 20:11:59 UTC
How would we capture the kernel dump?

I'm experiencing the same bug.  I don't consider it too serious, as it
happens when the system would normally be halted anyway.  It occurs in
stock RedHat kernels for both 5.9 and 6.0.  Kernels that I compile
myself have absolutely no problems.

------- Email Received From  Chaim Frenkel <chaimf@pobox.com> 05/24/99 17:01 -------

Comment 3 rbrown 1999-05-27 13:53:59 UTC
I have 2 boxes at home--one does this, the other doesn't.
On the good one, the output of halt is this (not verbatim, sorry):
  INIT: changing runlevel..
  Shutting down ____  (repeats a lot)
  The System is halted.
  Power down
(there's some new-to-2.2 "md_* awoken" messages in there, too)

On the bad system, it's the same until the last two lines:
  The System is halted
  Kernel Page Fault ... blah blah blah.. oops... blah blah...


So, AFAIK, the net effect is that instead of getting a single
line "Power Down", I get 2 pages of kernel error messages.
Pretty innocuous, but interesting (and ugly).

Comment 4 Jeff Johnson 1999-06-05 17:50:59 UTC
This bug is similar enough to #3100 that I'm going to coalesce.

*** This bug has been marked as a duplicate of 3100 ***


Note You need to log in before you can comment on or make changes to this bug.