Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 3006 - telnetd doesn't negotiate binary option correctly
Summary: telnetd doesn't negotiate binary option correctly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: telnet
Version: 5.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-24 17:26 UTC by kdb
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-15 17:19:57 UTC


Attachments (Terms of Use)

Description kdb 1999-05-24 17:26:56 UTC
The problem is that the version of telnetd you use can not
negotiate out of binary mode and actually has several other
subtle bugs in telnet option negotiation.  I would
recommend getting a newer version of the telnetd code from
somewhere, but as a stop-gap adding the following line of
code to the end of wontoption() in state.c will fix the
problem we are encountering:

set_his_state_wont(option);


Note You need to log in before you can comment on or make changes to this bug.