Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2994 - Silly permission checking by rpc.mountd
Summary: Silly permission checking by rpc.mountd
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: knfsd
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-24 05:12 UTC by ganesh
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-03 13:49:41 UTC


Attachments (Terms of Use)

Description ganesh 1999-05-24 05:12:48 UTC
mountd doesn't like IP addresses which it cant reverse
lookup ?
e.g. I have a private IP which is not in DNS and I want
it to mount a directory hosted on RH6.0 (on an ultra5).
this directory has been globally exported.
but I get permission denied on the client and
/var/log/messages contains
May 24 09:58:16 mira mountd[764]: mount request from unknown
host 192.168.101.20
paranoia is all very nice, but this is silly.
I've tried lines like
/export/home	192.168.0.0/16(ro)
but it just doesnt work. still the same problem.
then I added
192.168.101.20	janus.vxindia.veritas.com janus
to /etc/hosts
and now it says
May 24 10:37:03 mira mountd[1071]: refused mount request
from janus.vxindia.veritas.com: no export entry
*sigh* got me coming and going.
now I change /etc/exports to
/export/home	(ro)
and NOW it works.

and /etc/rc.d/init.d/nfs restart doesn't work.
HUP winds up killing half the daemons. stop and start
work sometimes. sometimes nfsd doesn't stop/start properly,
inspite of unloading/reloading all relevant modules.
May 24 09:50:28 mira rpc.nfsd: nfssvc: Address already in
use
(I'll try to get a reproducible case and report separately)

Comment 1 Jeff Johnson 1999-06-03 13:49:59 UTC
I just upgraded knfsd to 1.3.3 which includes this line:

Changes from knfsd 1.3.2:
1. Modified mountd to allow clients without IP address to hostname
map.

Please reopen this bug if knfsd-1.3.3-1 does not fix.


Note You need to log in before you can comment on or make changes to this bug.