Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 299 - Linuxconf should support all ppp options
Summary: Linuxconf should support all ppp options
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-04 15:35 UTC by Michael Meissner
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-11 20:24:23 UTC


Attachments (Terms of Use)

Description Michael Meissner 1998-12-04 15:35:36 UTC
Linuxconf should have buttons for each of the ppp options
that can be specified (along with a catchall to support new
options), with help for each option, so you can easily
determine what options to set, without having the NET-3
and/or pppd man page open while running linuxconf.

Glancing at the pppd 2.3.5 man page, options that should be
setable include: passive, bsdcomp, chap-interval,
chap-max-challenge, chap-restart, deflate, demand, domain,
holdoff, idle, ipcp-accept-local, ipcp-accept-remote,
ipcp-max-failure, ipcp-max-terminate, ipcp-restart, ipparm,
all of the ipx options, all of the lcp options, ms-dns,
ms-wins, noipdefault, all of the pap options, persist,
predictor1, vj-max-slots, welcome.

Comment 1 Jay Turner 1998-12-09 19:09:59 UTC
This is really an enhancement request, not a bug.

Comment 2 David Lawrence 1998-12-10 17:53:59 UTC
This has been assigned to a developer for future enhancement requests.

Comment 3 Michael K. Johnson 1999-02-11 20:24:59 UTC
I disagree with this request.  We specifically chose the options
that would be useful to the most people to avoid being confusing;
the other options are only useful to people who know what they
want to do anyway.  We are willing to consider adding specific
options, but we need a coherent argument why each particular option
would have wide use before adding it.


Note You need to log in before you can comment on or make changes to this bug.