Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2988 - emacs-nox attempts to use DOC file for emacs-x11
Summary: emacs-nox attempts to use DOC file for emacs-x11
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: emacs
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-05-23 23:02 UTC by Bryan Reece
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-11 21:17:26 UTC


Attachments (Terms of Use)

Description Bryan Reece 1999-05-23 23:02:54 UTC
With emacs-20.3-15 and emacs-nox-20.3-15 installed,
describe-function (C-h d) prints random pieces of doc
strings rather than the correct ones.  To reproduce,
try C-h d fround RET in emacs-nox.

The problem appears to be that the DOC string generated when
building emacs-nox is lost because both the X11 and non-X
versions get the same version number.  A possible fix would
seem to be to give the non-X emacs a different build number,
thus giving its doc file a different name.

------- Email Received From  bpreece@unity.ncsu.edu 05/26/99 19:21 -------

Comment 1 Alan Shutko 1999-06-29 20:39:59 UTC
Is there any reason to have both emacs and emacs-nox installed?  emacs
runs perfectly fine in character-mode.  The only difference is that
emacs is linked against the X libraries and emacs-nox is not, allowing
you to install emacs-nox if you don't have the X libraries.
Otherwise, you can just install emacs.

To use emacs (with X) in character-mode, either unset DISPLAY or start
it as emacs -nw.

Comment 2 Bryan Reece 1999-06-30 16:13:59 UTC
emacs-20.3-15 contains files common to both the X11 and non-X
versions.  It has no emacs binary.  One of emacs-X11-20.3-15 or
emacs-nox-20.3-15 is required to get a working installation.

The reason I don't just go ahead and use emacs-X11 on that machine is
that it is painfully slow on a small machine ("Eight Megabytes And
Constantly Swapping" is no longer a joke, at least with emacs 20.3
linked against X).

Comment 3 Cristian Gafton 2000-02-11 21:17:59 UTC
Patch applied and fixed in the current devel tree.


Note You need to log in before you can comment on or make changes to this bug.